Member Site Forums Rosetta 3 Rosetta 3 – General error running rosetta3.0 Reply To: error running rosetta3.0


    > Hi, I am new to Rosetta. I downloaded and built Rosetta3.0 today with the supplied script. It finished without any errors. Afterwards, I tried running AbinitioRelax.linuxgccrelease and I got the following error:
    > error while loading shared libraries: cannot open shared object file: No such file or directory
    > I’m not sure if this is a dependency issue or maybe I don’t have full permissions to those libraries (I just built this locally in my home directory). I am not the most linux savvy person out there, so maybe this is a relatively easy thing to fix. I noticed someone had this same problem (was posted in the other section) and no one was able to help.
    > Any ideas would be helpful. Thanks.

    I think your problem is it can’t find because it is not in the shared library path.

    I solved this by adding to my .bashrc file:


    export LD_LIBRARY_PATH

    of course you would have to change the path /data/home/apps/rosetta3/rosetta3_source/ to where you have installed rosetta on your system.