Member Site Forums Rosetta 3 Rosetta 3 – General SCons compilation error (Windows XP, 32bit) Reply To: SCons compilation error (Windows XP, 32bit)


    Right – thought I tried that with MinGW, but obviously not :)

    “mini” is the name most of the developers use for the Rosetta 3.x code. And looking more closely at your output from the first post, it looks like you’re using release 3.0, which answers my question. Generally I’m working with one of the later releases from the subversion repository, which is why I assumed you were.

    I’m wondering why your executables end in “.linuxgccrelease”. I’m also curious as to why you didn’t get the errors I did when I tried to use MinGW: on my machine, it was unable to find some of the basic typedefs, and couldn’t compile anything; I had to hack some things to get past that, and even then haven’t gotten it to compile with MinGW yet.

    Two questions: First, when you compile, where do your object and executable files end up? This will be somewhere in the rosetta3_source/build directory; you can either examine that directory, or look at your scons output. For example, on my linux box, I get this line for the “relax” executable, which shows it being placed in “build/src/release/linux/2.6/32/x86/gcc/static”: __g++ -o build/src/release/linux/2.6/32/x86/gcc/static/relax.linuxgccrelease -static build/src/release/linux/2.6/32/x86/gcc/static/apps/public/relax.o -Llib -Lexternal/lib -Lbuild/src/release/linux/2.6/32/x86/gcc/static -Lsrc -L/usr/local/lib -L/usr/lib -lprotocols -lcore -lnumeric -lutility -lObjexxFCL -lz__

    Second, when the links are made, where does it try to link to? On my linux box, this scons output line gives the answer: __Install file: “build/src/release/linux/2.6/32/x86/gcc/static/relax.linuxgccrelease” as “bin/relax.linuxgccrelease”__ I’m guessing that your MinGW build is trying to link somewhere other than where your compiled code is.