Member Site Forums Rosetta 3 Rosetta 3 – General ERROR: compiling rosetta3.1 with MPI Reply To: ERROR: compiling rosetta3.1 with MPI


    > Failing that – there are a vanishingly small number of files in Rosetta that use mpi.h. The original error suggests moving those headers to the top of those files. Why not try that?

    I tried that at first, and it worked for most of them, but I encountered that has a series of entangled includes that made it impossible (at least for me) to have mpi.h at the very top

    >I’m also reasonably certain the 3.1 stock abrelax is not MPI compatible. Do you need the MPI compatible version?

    right now I have to manually distribute the work if I want to take advantage of my cluster, for example, if I want to generate 10,000 models, I manually send 10 different jobs to produce 1,000 models each, in different directories. I would like to know if there is a better way to just send one job for 10,000 models and automatically distribute the work on a user defined number of nodes/cores (I thought MPI-PBS was the way to do this)