Member Site Forums Rosetta 3 Rosetta 3 – General high resolution protein docking doesn’t work Reply To: high resolution protein docking doesn’t work


    From that compiling command line, we haven’t actually activated the MPI compilation. This is consistent with the log file (I examined it further and it’s missing some of the MPI only output). MPI compilation is triggered by adding “extras=mpi” to the command line.

    If you use mpirun on a non-MPI Rosetta executeable (which I think you did), you’ll still get the jumbled log file you got.

    So, one thing to try is to recompile with extras=mpi. This will not overwrite your non-mpi binaries, but it may change the symlinks in the bin/ directory. Explore the build/ directory instead to find the mpi vs. non-mpi files.

    None of this addresses the root issue, that your inputs are not changing when they are output. I’m still not sure what’s causing that, but the log files sure look like Rosetta thinks it is working correctly.

    Try going to (rosetta_source)/test/integration and running the docking integration test with “python docking -d (path to database)”. See if the result is different from the input protein. Try putting your own protein in the input folder tests/docking/input and changing the flags file and seeing if that works.