Member Site Forums Rosetta++ Rosetta++ – Build/Install Error during installation of rosetta2.3 in Blue gene Reply To: Error during installation of rosetta2.3 in Blue gene


    Dear All

    I had tried compiling rosetta2.3 on IBM BlueGene using mpixlC compiler. I had compiled the program files at frontend mode of BlueGene to generate object files. I got the following warning:
    mpixlC -c -I. -Isrc -Iexternal/include -Isrc/platform/linux/ -O3 -qhot=nosimd -DNDEBUG -DUSEMPI -qarch=440 -qtune=440 -qmaxmem=-1 -qlanglvl=c99__func__ -MT.xlc++_ppc.void.d -MF.xlc++_ppc.void.d -o .xlc++_ppc.void.o
    1500-036: (I) The NOSTRICT option (default at OPT(3)) has the potential to alter the semantics of a program. Please refer to documentation on the STRICT/NOSTRICT option for more information.

    This warning was common to mostly all the object files created. I then tried to combine al the object files to get the final executable file: rosetta.xlc++_ppc at the backend mode using make xlc++_ppc, but, without the -q64 option in makefile i.e I compiled it using mpirun32.

    Though I was able to strip rosetta.xlc++_ppc from the object files generated, I was not able to run the program successfully. The program haults in the middle after generating few core files (error).

    core file:
    ended with software signal…….0x0000000b (SIGSEGV – segmentation violation)
    generated by interrupt………..0x0000000d (data TLB error interrupt)
    while executing instruction at…0x00c0b820
    dereferencing memory at……….0x48284444

    General Purpose Registers:
    r00=0x00c0b068 r01=0x3ffb4000 r02=0xdeadbeef r03=0x00000004
    r04=0x48284440 r05=0x01d7ee54 r06=0x3ffb4120 r07=0x02720000
    r08=0x02720000 r09=0x01e00000 r10=0x01d80000 r11=0x0b4e7ffc
    r12=0x00000004 r13=0xdeadbeef r14=0x00000004 r15=0x00000007
    r16=0x0270ac20 r17=0x00000005 r18=0x00000004 r19=0x00000240
    r20=0x00000000 r21=0x02709e60 r22=0x01d7f670 r23=0x3ffb4580
    r24=0x3ffb4430 r25=0x0000000a r26=0x3ffb4490 r27=0x3ffb44c0
    r28=0x00000000 r29=0x024904d0 r30=0x01d7f670 r31=0x3ffb40f0

    The program haults at :

    Filling missing atoms
    optimizing missing atoms
    [T/F OPT]Default FALSE value for [-disallow_hbond_o4star]
    [T/F OPT]Default FALSE value for [-disallow_hbond_ho2star]

    I am looking forward for any suggestion regarding this.

    Thanking you…….