Member Site Forums Rosetta 3 Rosetta 3 – General mpi / jd2 with AbinitioRelax and relax (3.2) Reply To: mpi / jd2 with AbinitioRelax and relax (3.2)


    I want to use the 4 cores on my computer to finish a rosetta relaxation protocol ~4 times as fast. I ran >mpirun -np 4 relax.linuxgccrelease -s input.pdb @flags. NB the -overwrite flag was not present. I had scores of 4 structures named input_0001 and input_0002 (with different scores), but only one copy structure (presumably the last one, the others were overwritten).

    Perhaps I need to install the mpi executables?

    I would like the mpi patch for 3.2 – 3.3 is not working as well at this point. I tried to recompile rosetta to include protocols like relax.mpi.linixgccrelease (right now I just have relax.linuxgccrelease, relax.default.linuxgccrelease, relax.linuxgccdebug) by running
    >scons mode=release bin extras=mpi

    however I got the following error

    scons: Reading SConscript files …
    svn: ‘.’ is not a working copy
    scons: done reading SConscript files.
    scons: Building targets …
    mpiCC -o build/src/release/linux/2.6/64/x86/gcc/mpi/apps/public/AbinitioRelax.o -c -std=c++98 -pipe -ffor-scope -W -Wall -pedantic -Wno-long-long -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -DNDEBUG -DUSEMPI -Isrc -Iexternal/include -Isrc/platform/linux/64/gcc -Isrc/platform/linux/64 -Isrc/platform/linux -Iexternal/boost_1_38_0 -I/usr/local/include -I/usr/include src/apps/public/
    sh: mpiCC: command not found
    scons: *** [build/src/release/linux/2.6/64/x86/gcc/mpi/apps/public/AbinitioRelax.o] Error 127
    scons: building terminated because of errors.