error running rosetta3.1 demos

Member Site Forums Rosetta 3 Rosetta 3 – General error running rosetta3.1 demos

Viewing 2 reply threads
  • Author
    • #673

        Hello, I compiled Rosetta3.1 on Ubuntu 8.2, the complie is fine no error report. Then I run some example under rosetta_demons/ directory according to the readme file in the directory, and I have errors:

        for rosetta_demos/Ligand_Docking, the error is :

        ERROR: Unable to open file: ./silent.out

        ERROR:: Exit from: src/protocols/jobdist/JobDistributors.hh line: 825


        for rosetta_demos/Docking, the error is:

        ERROR: Option matching -dock_mcm not found in command line top-level context


        I donot know what is the problem, did I miss something when I install Rosetta3.1?  I am new user of Rosetta, any one tell me what should I do to get rid of these errors?




      • #4623

          “ERROR: Unable to open file: ./silent.out”


          I would guess you are running the test in a directory for which you do not have write permission.  Rosetta is saying it can’t write to that file; probably you don’t have write access to the directory you’re running in.




          “ERROR: Option matching -dock_mcm not found in command line top-level context”

          The documentation is out of date.  I believe dock_mcm is the default, so you no longer need to specify it.  If you’ll examine rosetta_source/test/integration/tests/docking instead, you’ll see that the option is commented out in the flags file for that test.

        • #4624

            Thanks, problem solved.

        Viewing 2 reply threads
        • You must be logged in to reply to this topic.