Using Rosetta Docking for nucleic acids

Member Site Forums Rosetta 3 Rosetta 3 – Applications Using Rosetta Docking for nucleic acids

Viewing 3 reply threads
  • Author
    • #886


        I tried to use RosettaDock with protein-nucleic acid chains. But I have a problem. Rosetta doesn’t seem to recognise nucleic acids with the parameters I used. Here is the error message:

        ERROR: unrecognized aa U
        ERROR:: Exit from: src/core/io/pdb/ line: 534

        The version of RosettaDock I compiled (3.2.1) worked with the protein-protein complexes I tried.

        I suppose there is a command to specify nucleic acids or a specific database to use. Can anybody please tell me how to use RosettaDock for protein-nucleic acid chains?

        Thanks in advance.

      • #5497

          U is an RNA nucleic acid. Non-RNA Rosetta executeables recognize only DNA by default, because the DNA and RNA names conflict, and the authors decided to offer one-or-the-other instead of figuring out a system for both. Are you doing RNA-protein complexes or DNA-protein complexes?

          If this is not the problem it’s probably a nomenclature thing. Your residue names need to match what Rosetta has in its parameter files in the database (database/chemical/residue_type_sets/fa_standard/ or something like that). Note that the RNA is NOT in the fa_standard set, but DNA is. If you’re using DNA I can help you debug this path.

        • #5498

            I’ve never done anything with RNA or DNA, but there’s a manual page about using RNA (, although it doesn’t seemed to be linked through the main documentation page. (But can be found by searching the online manual for “RNA”.)

          • #5942

              I use RNA-protein complexes. I am reading the manual page about RNA. Thank you for the link. I will tell you if I have any trouble or solution.

          Viewing 3 reply threads
          • You must be logged in to reply to this topic.