ab initio membrane error (frag9 file…)

Member Site Forums Rosetta 3 Rosetta 3 – Applications ab initio membrane error (frag9 file…)

Viewing 3 reply threads
  • Author
    • #1363

        Hi all…

        I’m running the ab initio membrane app as…

        almeida@IDBiotum7:/modelacion/Rosetta$ membrane_abinitio2.linuxgccrelease -abinitio:membrane -in:file:fasta ../P13866.fasta -in:file:spanfile sglt1.span -nstruct 5 -in:path:database /home/almeida/Softwares/Rosetta/rosetta_3.4/rosetta_database/

        … and I got this error: ‘ERROR: Value of inactive option accessed: -in:file:frag9’

        How do I generate the frag9 file for my protein sequence?

        Thanks in advance…

      • #7507

          The easy way is the Robetta server: http://robetta.bakerlab.org/fragmentqueue.jsp

          The other way is to generate fragments yourself with Rosetta: http://www.rosettacommons.org/manuals/archive/rosetta3.4_user_guide/dc/d10/app_fragment_picker.html

        • #10195

            I have utilized the robetta server to get my protein model, after a month of submission i have got an ETC status error. I have waited for a month to get results unfortunately it’s showing error. Please help me out to retrieve my protein model.

          • #10196

              Thanks in advance

            • #7514


                The Robetta server solved the problem :)

                Now, when I run the command, only two output files are generated: default.out and score.fsc

                How to generate the .pdb files for each solution. I wrote the command for 5 output models (-nstruct 5) as:

                almeida@IDBiotum7:~/modelacion/Rosetta$ membrane_abinitio2.linuxgccrelease -in:file:fasta ../P13866.fasta -in:file:spanfile sglt1.span -nstruct 5 -in:path:database /home/almeida/Softwares/Rosetta/rosetta_3.4/rosetta_database/ -in:file:frag9 robetta/aaSGLT109_05.200_v1_3 -score:find_neighbors_3dgrid -in:file:frag3 robetta/aaSGLT103_05.200_v1_3 -abinitio:membrane -membrane:Menv_penalties

                I’m doing some testing runs before to send a job with 10 000 solutions.


              • #7515

                  default.out is a “silent file”, which is a Rosetta-specific file format for compressed structure storage.

                  For doing five files, you may be able to add -out:file:pdb or something similar to get PDB output instead of silent files. This is not recommended for a run of 10,000 PDBs – putting 10000 files in one folder will make your filesystem angry.

                  To extract from silent files, the way I prefer is score_jd2.linuxgccrelease -in:file:silent (silent file name) -out:file:pdb -in:file:tags (list of which structure tags you want). There are lots of other silent file extractors floating around in the release as well. (I may have some of the flags slightly wrong off the top of my head).

                • #7516

                    Thanks for the tip…!!

                    I ran your sugestion as:

                    “score_jd2.linuxgccrelease -in:file:silent default.out -in:file:tags S_00000001 -out:pdb -in:path:database /home/almeida/Softwares/Rosetta/rosetta_3.4/rosetta_database/”

                    .. and I got this error:

                    ERROR: Illegal attempt to score with non-identical atom set between pose and etable
                    ERROR:: Exit from: src/core/scoring/etable/EtableEnergy.cc line: 75


                    What is the difference between ‘score’ and ‘score_jd2’ application?

                  • #7517

                      “ERROR: Illegal attempt to score with non-identical atom set between pose and etable”

                      This means you’re scoring a centroid pose with a fullatom scorefunction. You need to score with score3 instead (-weights score3, maybe?). You could also try extract_pdbs.linuxgccrelease, or score.linuxgccrelease. score and score_jd2 are basically the same thing for the purposes at hand.

                    • #7519

                        I used ‘extract_pdbs.linuxgccrelease’ succesfully…


                      • #10203

                          CASP has been going on recently, so the Robetta server has been turned over to primarily working on internal CASP modeling, so external submissions may take quite a while to complete. CASP is winding down this month, so the backlog of modeling should start to be addressed. Also, as the Robetta page says “Jobs may be removed one week after they complete to conserve disk space”, so if you did not download the results in that time (you should have gotten an email when the job was completed), the results may no longer be around.

                          Apart from that, a job ID for the job in question would help in debugging the issue.

                          P.S. It’s best to start a new thread for different issues.

                      Viewing 3 reply threads
                      • You must be logged in to reply to this topic.