Can’t append or prepend with pepspec

Member Site Forums Rosetta 3 Rosetta 3 – Applications Can’t append or prepend with pepspec

Viewing 1 reply thread
  • Author
    • #2173

        Hi there

        I have the basic pepspec working nicely, but I’d like to try the options to append or prepend. My flags look like this

        -database /home/daniel/progs/rosetta_2014.16.56682_bundle/main/database
        -in:file:s best_relaxed.pdb
        -o best_relaxed_append_test
        #tips says basically use these
        -extrachi_cutoff 0
        -pepspec::n_peptides 1000
        -pepspec::pep_chain D
        -pepspec::pep_anchor 490

        -pepspec::n_append 1

        Without the last line it runs fine. With it (or the equivalent prepend) I get this error message

        ERROR: moving_connection.icoor().is_internal() && fixed_connection.icoor().is_internal()
        ERROR:: Exit from: src/core/conformation/ line: 97

        The only other mention of this error I can find seems to be for an unrelated application so I’m really stuck.

        Thanks for any help


      • #10922

          What does your PDB look like? Is it all amino acids without modifications, or do you have non-protein residues or terminal modifications (like amidation or acylation) ? Is it just two chains (the receptor and the peptide) or do you have multiple chains? Which order do the chains go, receptor-peptide or peptide-receptor? Is the extent of the peptide and receptor being accurately determined by Rosetta (look at the tracer output)? Are there any other warning or error messages being printed to the tracer?

          Also, take a look at and try working through the demo at Rosetta/demos/public/peptide_specificity/ which should have an example of using the -pepspec::n_append option.

        • #10928

            Thanks for your thoughts.
            The PDB file input is perfectly standard. No odd residues, receptor chain A followed by peptide chain D. The termini are properly modelled with amino and carboxylic acid groups, appropriately (de) protonated (NH3+ and CO2-). There are also two reasons to think the format should not be an issue a) it is the output of a previous Rosetta relax step and b) if I predict peptide specificity for the peptide alone, without prepend or append, everything goes just fine.
            There’s nothing fishy in the logfile (attached).

            The demo does include prepend and append but requires files generated in a first step. When I run the first step it rapidly gobbles up half my memory (8/16 GB), then starts to run very slowly while making my machine unworkable. I’m not going to be able to get the files to test the second step with the append and prepend.

            I’m grateful for any more ideas. Has anything changed in pepsepc recently? – is it worth updating from my rosetta_2014.16.56682_bundle?


          • #10964

              Hello, I have the same issue as the original poster, down to the same error messages and an identical inability to run the demo provided in the documentation for pepspec.

          Viewing 1 reply thread
          • You must be logged in to reply to this topic.