Compilation error

Member Site Forums Rosetta 3 Rosetta 3 – General Compilation error

Viewing 1 reply thread
  • Author
    • #450

        I’m trying to compile the rosetta on two machines, one x86-64 and other x86.
        On both I get the same error:

        g++ -o build/src/release/linux/2.6/64/x86/gcc/protocols/toolbox/PoseMetricCalculators/ResidueDecompositionByChainCalculator.os -c -std=c++98 -pipe -ffor-scope -W -Wall -pedantic -Wno-long-long -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -fPIC -DNDEBUG -Isrc -Iexternal/include -Isrc/platform/linux/64/gcc -Isrc/platform/linux/64 -Isrc/platform/linux -Iexternal/boost_1_38_0 -I/usr/local/include -I/usr/include src/protocols/toolbox/PoseMetricCalculators/
        src/protocols/toolbox/PoseMetricCalculators/ In member function ‘void protocols::toolbox::PoseMetricCalculators::ResidueDecompositionCalculator::residue_set_numbers_to_decomposition()’:
        src/protocols/toolbox/PoseMetricCalculators/ internal compiler error: Segmentation fault
        Please submit a full bug report,
        with preprocessed source if appropriate.
        See for instructions.
        scons: *** [build/src/release/linux/2.6/64/x86/gcc/protocols/toolbox/PoseMetricCalculators/ResidueDecompositionCalculator.os] Error 1
        scons: building terminated because of errors.

        I tried g++ 4.4 and 4.2 using mode = release.

      • #4349

          This is a known issue with g++ 4.4.1. It’s a bug in the compiler, not a bug in the code.

          I don’t believe it’s been seen before with g++ 4.2.

          I use g++ 4.3.2 and have not had any trouble, even on machines where g++ 4.4.1 did not work. I am told that g++ 4.4.2 has fixed this bug. We don’t plan on patching this issue – we can duplicate it but it’s really a compiler bug and we don’t know how to address it.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.