Compiling Rosetta++ 3.1 with alternate gcc

Member Site Forums Rosetta++ Rosetta++ – General Compiling Rosetta++ 3.1 with alternate gcc

Viewing 1 reply thread
  • Author
    • #632

        Hi there folks,

        I have been struggling for a few days now to get scons to use an alternate version of gcc that I have installed in my home directory on a Ubuntu workstation. I have tried editing the rosetta_source31/tools/build/user.settings and edited the program_path to import the current $PATH which includes the gcc compiler (compatible) with Rosetta, but it still fails to find it. I have also tried editing SConstruct, and added pointers to point to gcc and g++ but still no luck. The last thing I did, which I didn’t really want to do, was to change the gcc and g++ symlinks in /usr/bin to point to the alternate gcc/gpp pairs. This works but requires root privledges and isn’t really a clean way of getting Rosetta to compile.

        Can someone please advise what a clean way would be to let scons find the alternate gcc version which I can provide to it as a parameter or edit a configuration file?

        Thanks so much.


      • #4518

          A) This is the Rosetta++ board (Rosetta 2.x), you probably meant to post this on the Rosetta 3.x board.

          B) You should try asking around on scons sites as well – this is really a scons question not a rosetta question.

          C) I would try naming (or symlinking) YOUR gcc’s something else, like my_gcc, then editing scons to use my_gcc instead of gcc. It will never find the default gcc’s, since the name is now changed, so it’s forced to go look for yours.

          D) You may want to examine the cxx flags. I know you use cxx=icc on the compile command line to get intel compilers; I’ve also used cxx = gcc### (where ### is a version number) to get rosetta to use a particular installed version of gcc when there was more than one available.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.