Coordinates in pose do not match those in PDB

Member Site Forums PyRosetta PyRosetta – General Coordinates in pose do not match those in PDB

Viewing 1 reply thread
  • Author
    • #2048

        When I load a PDB file the coordinates for residue 18 (R1A) reported by pyrosetta do not match those found in the PDB. An example notebook is attached.

        What is the reason for this mismatch and how could I fix it? Is it connected to the internal coordinates of R1A.params?

        The CB atoms of the other residues (ALA)  are correct.

        Thank you for your help and best regards,


      • #10497

          You have zero occupancies in some of the heavy atoms in your structure (particularly the R1A residues). Default behavior by Rosetta is to throw away those atoms and rebuild them. The rebuilt location will not necessarily match the input location. Furthermore, Rosetta also tends to repack residues which have missing atoms on loading (because, generally speaking, the rebuilt-from ideal positions will not be compatible with the rest of the protein structure. The way it does this permits movement of sidechain atoms, including atoms which may have specified coordinates. (You won’t see movement of the CB atoms, because rebuilding and packing of those atoms will always place them in the same spot, given the same backbone atoms.)

          You can change the behavior towards the zero occupancy atoms by passing the commandline parameter “-ignore_zero_occupancy false” when you do your Rosetta initialization. I don’t believe you can change the repacking on incomplete reside behavior, so you’ll want to make sure that you include input coordinates for all (heavy) atoms. Keep in mind that Rosetta bases presence/absence on atom names, so the names you use in the input PDB must match up with those Rosetta expects.

        • #10505

            I was using the occupancy column as a flag to tell NAMD which atoms to restrain (and forgot about it). So I just set all the occupancies to 1.00 and now everything is working perfectly.

            Thank you very much!

        Viewing 1 reply thread
        • You must be logged in to reply to this topic.