Member Site Forums Rosetta 3 Rosetta 3 – General enzdes error

Viewing 1 reply thread
  • Author
    • #1380

        I’m trying to learn enzdes using tutorials in demo and in the paper “de novo enzyme design using rosetta3”. The first several steps went well, but when I tried the actual design step, I got this error: ERROR: Illegal value for real option -enzdes:cut1 specified: 6.0. This does not make sense at all. Anyone can help with this? Thanks.

      • #7640

          What does your command line and flags file look like?

        • #7642

            Here are the flags I used:
            -s UM_1_E41H272K271_1TML_mocktim_1.pdb
            -extra_res_fa 1n1.params
            -enzdes:cstfile mocktim.cst
            -enzdes:cut1 6.0    
            -enzdes:cut2 8.0     
            -enzdes:cut3 10.0      
            -enzdes:cut4 12.0  
            -enzdes:design_min_cycles 3
            -enzdes:lig_packer_weight 2
            -packing:linmem_ig 10  

            Here is the command line:
            rosetta3/rosetta_source/bin/enzyme_design.linuxgccrelease -database ~/rosetta3/rosetta_database/ @tim.flags

          • #7675

              I don’t know why you’re getting that error. The best I can come up with is that there is some sort of invisible/non-printing character after the “6.0” which is confusing the options reader. My suggestion would be to re-type the flags file (*don’t* copy & paste, lest you copy & paste the non-printing character) and retry it.

            • #7679

                Thank you very much for your great help, Rocco! I rewrote the flag file and it works now. It’s definitely an error caused by some invisible characters.

            Viewing 1 reply thread
            • You must be logged in to reply to this topic.