error about ‘std::bad_alloc’ during running

Member Site Forums Rosetta 3 Rosetta 3 – General error about ‘std::bad_alloc’ during running

Viewing 3 reply threads
  • Author
    • #735


        I just installed rosetta and used a small peptide to see whether rosetta worked properly. But when I run in the ‘rosetta’ directory, it aborted at a ‘Stage 4’ sometime later. The following is the screen message,

        Stage 4
        Folding with score3 for 40000
        terminate called after throwing an instance of ‘std::bad_alloc’
        what(): std::bad_alloc

        How to fix this problem?

        Many thanks!

      • #4813

          bad_alloc means something low down in C++ (lower than Rosetta) has gone wrong.

          The usual cause is that you ran out of memory, but that doesn’t seem likely for abinitio with a peptide (which is what I think you’re doing).

          Perhaps something is wrong with the compilation, and there’s some sort of mismatch between Rosetta and the underlying C++ library? Was this in Windows?

          • #4814

              Hi, yeah, it is a 10-amino acid peptide.
              This problem took place on my two computers, one of which is ubuntu and the other one is opensuse.

          • #4817

              Hi, what is the problem? I use gcc/g++-4.3 in ubuntu10.04 and opensuse13. Many thanks.

            • #4823

                I’d tell you if I knew. I’ve asked several developers and none of us have a clue what would cause that code to throw bad_alloc errors, other than the obvious issue of running out of memory.

                Can you test to ensure that it’s not running out of memory? How much is on the machine and how much gets used when it crashes?

                Can you run it in debug mode (compile without mode=release) to see precisely what allocation is crashing? This will unfortunately be very, very slow…

            Viewing 3 reply threads
            • You must be logged in to reply to this topic.