error in installation

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install error in installation

Viewing 2 reply threads
  • Author
    • #683

        hi everyone

        I am trying to install rosetta on ubuntu maverick (10.10) and having troubles with it …. I tried to install with a lower version of gcc-4.2 (as suggested in the installation guide) instead of the gcc-4.4 (default for maverick) but it is giving the same error at one file:

        /src/core/scoring/ 618 internal compiler error: Segmentation fault

        is there anyone facing the same problem or know anything about how I go about solving it .. please let me know


      • #4649

          I’m not aware of any developers using Ubuntu 10.10. Did you remember to tell SCons to use gcc 4.2 instead of 4.4? Even with both installed, SCons will probably default to 4.4.

          Generally, we’ve found that internal compiler errors are due to flaws in optimization. As a community, we solve these problems by using different compilers/OSes rather than changing the Rosetta code itself.

          Try putting extra, irrelevant statements in near the offending line to break up the optimization. This will make SASA calculation slower, but may be worth the cost.

          You can also try turning off optimizations by changing the settings in release mode in tools/build/basic.settings. Search for “gcc, release” in that file and try turning the flags off one at a time. This will drastically slow release-mode rosetta.

        • #4673

            Hi yogihooda88,
            I have been trying to install Rosetta in ubuntu too, if you find a way to do it could you tell write a little note on how?
            Thanks in advance,

        Viewing 2 reply threads
        • You must be logged in to reply to this topic.