error when compiling on ubuntu-10.10

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install error when compiling on ubuntu-10.10

Viewing 4 reply threads
  • Author
    • #893

        I had tried to compile (build) rosetta-3.2 on PC running Ubuntu-10.10 (64 bits),
        I have conducted downgrade of gcc to version 4.1,
        with this command:

        $/> ./scons bin mode=release

        but, after approx. half an hour compiling, I got the following errors:

        -Lsrc -L/usr/local/lib -L/usr/lib -lObjexxFCL -lz
        /usr/bin/ld: cannot find -lz
        collect2: ld returned 1 exit status
        scons: *** [build/src/release/linux/2.6/64/x86/gcc/] Error 1
        scons: building terminated because of errors.

        What should I do to resolve this errors?

        I am looking forward for any suggestion regarding this.
        Thanking you…….


      • #5513

          It looks like you’re having problems with the zlib compression library. Make sure you’ve installed the library on your system. If it’s not installed, I believe that an “apt-get install zlib” on the command line will fork for Ubuntu. You may have to also install the developer libraries as well (“apt-get install zlib-devel”)

          Additionally, there is a zlib version included in rosetta_source/external/lib/z.lib which sometimes confuses windows builds ( – I don’t know if that would be an issue for Ubuntu builds, though.

          P.S. This is actually the (sub)forum for the Rosetta 2.x (Rosetta++) series. Rosetta 3.x (“mini”) is quite a bit different, and has it’s own set of (sub)forums on

        • #5518

            Specifically, the package is zlib1g-dev.

            As root: “sudo apt-get install zlib1g-dev”, then recompile.

          • #7843

              hi I downloaded rosetta 3.4 codes recently…..
              I ran scons bin mode=release
              But I am not getting any linuxgccrelease files, only getting .os files.
              Nothing in /bin directory.
              Please help.

            • #7865

                I am getting .os files.

              • #5561

                  Dear Moretti,
                  Thank You very much for your help.
                  I have compiled it and success.


                • #5562

                    Dear SMLewis,
                    Thank you very much for your help.
                    I have recompiled it, and success.


                  • #5718

                      I have the same problem.
                      scons: *** [build/src/release/linux/2.6/64/x86/gcc/] Error 1
                      scons: building terminated because of errors.

                      Can you tell me your solution in detail?

                    • #5719

                        “building terminated because of errors” is a generic error message used when anything goes wrong. To better determine what specifically went wrong in your case, we’d need to see more context – e.g. the five-or-so lines prior to that final message.

                      • #7844

                          What output did you get from scons?

                        • #7866

                            What Steven meant was what sort of output to the console (stdout/stderr) are you getting? When you run scons, what is it printing? Is there any sort of error message?

                            Probably the best thing is to copy and paste the last page or so of the console output, and post it to this thread. Usually if you re-run scons, it will exit with an error message quickly, and there will be less than page of output total, in which case you can post all of it.

                            (I have the suspicion that your problem (getting .os files but no executables) is probably the no zlib problem that crops up frequently. Read the other posts in this thread to see how to fix it.)

                        Viewing 4 reply threads
                        • You must be logged in to reply to this topic.