error while building rosetta++

Member Site Forums Rosetta++ Rosetta++ – Build/Install error while building rosetta++

Viewing 3 reply threads
  • Author
    • #792


        I am new to rosetta. When i am trying to build rosetta by typing make gcc,i am getting a long message a part of which looks like this:

        src/utility/io/zipstream.ipp:657: instantiated from ‘void zlib_stream::basic_zip_ostream::add_footer() [with Elem = char, Tr = std::char_traits, ElemA = std::allocator, ByteT = unsigned char, ByteAT = std::allocator]’
        src/utility/io/zipstream.hpp:464: instantiated from ‘zlib_stream::basic_zip_ostream, unsigned char, std::allocator >& zlib_stream::basic_zip_ostream::zflush_finalize() [with Elem = char, Tr = std::char_traits, ElemA = std::allocator, ByteT = unsigned char, ByteAT = std::allocator]’
        src/utility/io/ozstream.hh:94: instantiated from here
        src/utility/io/zipstream.ipp:598: warning: dereferencing type-punned pointer will break strict-aliasing rules
        make: *** [.gcc.pose.o] Error 1

        i use a ubuntu 10.10 system and tried to use gcc64,gcc64debug and all other available options but still it is giving the same message.Can anybody tell whats going wrong here??

        Thanks in advance

      • #5047

          A) I thought we moved Rosetta++ to scons? Did you try the scons build?

          B) I know nobody has tried building Rosetta++ on a gcc that ships with Ubuntu 10.10. You may need to downgrade GCC significantly.

          C) I’m not sure that’s an error – that looks like a warning, maybe there’s an error elsewhere in the log.

        • #5166

            when I built rosetta++ by`/home/user/rosetta++/rosetta.gcc`, I came across an error. It was shown as follows:
            `Rosetta mode: abinitio
            [T/F OPT]Default FALSE value for [-chain_id]
            [T/F OPT]Default FALSE value for [-protein_name]
            [T/F OPT]Default FALSE value for [-series_code]
            This mode requires that the series_code protein_name and chain_id be defined (no hyphens allowed)

            The first three arguments must be:
            series_code protein_name chain_id
            use command line options:
            -series -protein -chain
            ERROR:: Exit from: line: 525
            I thought the paths file was correctly set up.

            How could I deal with it? Would anyone help me? Thanks for any suggestion in advance.

            PS: I have successfully installed rosetta3.2, and operated it well (so maybe it was not a problem about gcc or scons version). However, I still would like to use some other functions in rosetta++.

            Thanks very much.

          • #5172

              I think this is the error you ought to get if you run rosetta.gcc with no arguments. What did you want it to do? This isn’t an issue with the paths file, it wants you to give it more command line commands.

          Viewing 3 reply threads
          • You must be logged in to reply to this topic.