errors while running rosetta 3.1

Member Site Forums Rosetta 3 Rosetta 3 – General errors while running rosetta 3.1

Viewing 3 reply threads
  • Author
    • #909

        I have two queries regarding ab initio structure prediction with cs-rosetta using rosetta-3.1:
        a) For one of the runs while using the script default.out I get the error ERROR: did not find coordinates for all sequence positions for empty_tag
        and only one pdb is generated. The program is still running though.
        b) I am running an abinitio structure prediction calculation with rosetta 3.1. I have generated the fragment files from the robetta server. However, on running the command I get the error ‘ore.fragments.ConstantLengthFragSet: line too short: Skipping line ‘ a number of times and the program stops running.
        Any help regarding these two problems will be highly appreciated.

        Thanks in advance,
        Ishita Sengupta.

      • #5593

          I’ve never used CSrosetta, but both errors sound to me like you have a number-of-residues mismatch somewhere in your process. For example, you want to predict the structure of a 90 residue protein, but you generated fragments using the FASTA for only 85 residues’ worth of protein. Rosetta is not smart enough to silently add things like 6xHis-tags to the ends of proteins (or remove them). That’s the first place I’d look for a solution.

        • #5612

            I have another question.
            The script has a few lines which I don’t completely understand. I tried looking in the manual, but could not find them.
            What do the following terms mean?
            -increase_cycles 10 -rsd_wt_helix 0.5 -rsd_wt_loop 0.5 -rg_reweight 0.5 ?

            Thanks again,
            Ishita Sengupta.

          • #6044

              Sorry, for bringing this up again but I have the same problem and this seems to be unresolved, yet.

              I am also trying to use RDCs in my calculations. I found a reference for this (Sgourakis, 2011, JACS) and was told that this will be available with 3.3.
              Now adding the following lines to my 3.3 protocol:
              -in:file:rdc rdc_data.dat
              -score:patch rdc_patch_file

              while “rdc_patch_file” is just:
              rdc 10.0
              atom_pair_constraint 5.0

              gives the following message during initialization of the run:
              core.scoring: could not parse line in patch-file: rdc 10.0
              core.scoring: could not parse line in patch-file: atom_pair_constraint 5.0

              The run finishes without problems but I am not sure whether the RDCs were accounted for. Adding arbitrary values as RDCs does not change much, so my guess is, the input-file is ignored.
              What may I have missed?

            • #5623

                These are guesses:

                core::options::OptionKeys::abinitio::increase_cycles, “Increase number of cycles at each stage of fold_abinitio (or pose_abinitio) by this factor” ).lower(0.001).def(1.0)

                core::options::OptionKeys::abinitio::rsd_wt_helix, “Reweight env,pair,cb for helix residues by this factor”
                (env, pair, and cb are scorefunction terms in centroid mode. pair handles electrostatics (such as they are); you should be able to look the others up in the Rohl review (2004 methods in enzymology)

                core::options::OptionKeys::abinitio::rsd_wt_loop, “Reweight env,pair,cb for loop residues by this factor”

                core::options::OptionKeys::abinitio::rg_reweight, “Reweight contribution of radius of gyration to total score by this scale factor”

              • #5662

                  Thanks a lot!
                  I found documentation from rosetta 2.3 user guide that explains these terms.
                  I have another question.
                  I am running rosetta 3.1 with rdc constraints.
                  I am not sure how the input file should be or if rosetta 3.1 accepts the dipolar coupling constants at all.
                  flags file is :

                  -in:file:fasta trunc.fasta
                  -in:file:frag3 input/
                  -in:file:frag9 input/
                  -constraints:cst_weight 1
                  -constraints:cst_file rdc
                  -out:nstruct 2
                  -out:file:silent test.out
                  -out:pdb true
                  -out:path .

                  my rdc file is
                  10 N 10 H -11.407
                  11 N 11 H -10.639
                  12 N 12 H -7.626
                  13 N 13 H -10.212
                  14 N 14 H -12.215
                  15 N 15 H -8.948
                  16 N 16 H -7.531
                  17 N 17 H -11.159
                  18 N 18 H -11.65
                  74 N 74 H -8.485
                  75 N 75 H -7.471
                  76 N 76 H -13.03
                  77 N 77 H -11.264
                  78 N 78 H -9.004
                  79 N 79 H -9.42
                  80 N 80 H -13.559
                  81 N 81 H -8.236

                  but everytime i run AbinitioRelax.linuxgccrelease @flags -database

                  I get the error (last few lines of log file)
                  core.scoring.constraints: Constraint choice: rdc
         read constraints from rdc
         read constraints section –NO_SECTION—
         no section header [ xxx ] found, try reading line-based format… DON’T MIX
         read constraints from rdc

                  ERROR: 10 does not name a known ConstraintType –> check spelling or register new Constraint type in ConstraintFactory!
                  ERROR:: Exit from: src/core/scoring/constraints/ line: 58

                  It seems like the rdc constraint file is not being recognized at all.

                  In the “using constraints section” of the rosetta-3.1 user manual I could not find any example with rdc data.

                  Any help would be highly appreciated.

                  Thanks again,

                • #5668

                    The standard constraint file format does not accept RDC data. I’ve tried in the past to get those who know how to do it to document it, but it hasn’t happened yet.

                    All the RDC stuff is in the 3.2.1 release but I can’t trace it back to the actual executeable.

                    There are multiple options referencing “rdc” in the options list:

                    Maybe one of them will work?

                  • #6045

                      I was too quick posting this question. The patch file has to look like this “rdc = 1.0” or “rdc *= 1.0” with the spaces between name and number. Of course “*=” makes only sense for a predefined score.

                  Viewing 3 reply threads
                  • You must be logged in to reply to this topic.