excecutable files don’t work — Rosetta3.2 on WindowsXP

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install excecutable files don’t work — Rosetta3.2 on WindowsXP

Viewing 2 reply threads
  • Author
    • #790

        I tried installing rosetta 3.2 on windows XP using cygwin1.7, gcc 3.4.4. following a procedure posted on 10/20/2009.

        It seems I was able to compile rosetta3.2. There are “executable files” in rosetta_source/bin folder and rosetta_source/build/src/release/cygwin/1.7/32/x86/gcc folder. They look like AbinitioRelax.cygwingccrelease, backrub.cygwingccrelease and so on.

        Unfortunately they don’t work at all. I just get this message “Segmentation fault(core dumped)” when I try to calculate sample data in rosetta_demos folder. Has anyone encountered the same problem? How did you solve it?

        Here is what I did.

        1. started cygwin
        2. changed directory to rosetta_demos/abinitio
        3. typed a command: ../../rosetta_source/bin/AbinitioRelax.cygwingccrelease @flags -database ../../rosetta_database/

        “Segmentation fault (core dumped)” is the only message on the screen returned by cygwin.
        I have also tried other executable files but no success.

        Any information would be helpful for me.

        Thank you.

      • #5038

          Sounds like it’s not compiling correctly; probably all the executeables are compiled incorrectly.

          Try a different executeable (score or fixbb) – do they also fail immediately? Try running the executeable with no options or arguments – does that fail? If so, it’s a compiling issue.

          You could *try* compiling the debug executeable (mode=debug on the scons command line) and running this in a debugger to try to catch the segfault; but I suspect it’s immediate or even before Rosetta proper starts in the C++ preinitialization, so this won’t be useful.

          Unfortunately the simple fact that it fails to run is insufficient information to figure out how to fix it. I’m no expert on Windows compiling as it is (I’ve never done it; someone in my lab has tried but I don’t think he’s managed it yet).

        • #5052

            Thank you for your quick response. I am trying a few things including your suggestions.

        Viewing 2 reply threads
        • You must be logged in to reply to this topic.