Failure to find libraries during build

Member Site Forums Rosetta 3 Rosetta 3 – General Failure to find libraries during build

Viewing 3 reply threads
  • Author
    • #638

        I’m trying to build Rosetta 3.0 on Ubuntu 10.4. I think I’ve solved all the problems on the Ubuntu side of things, but I think I’m having a problem with the code itself now. When I run SCons, I get the following error.

        /usr/bin/ld: cannot find -lz
        collect2: ld returned 1 exit status
        scons: *** [build/src/release/linux/2.6/32/x86/gcc/] Error 1

        From what I can gather, it goes looking for a dynamic library and I think it’s got the wrong target location. What can I do to correct the target location?

      • #4512

          Finally! An Ubuntu build problem, not a windows problem! (I have Ubuntu, and no access to windows machines, so I’m mostly clueless on helping build on windows).

          Open the package manager and install zlib1g-dev. Building rosetta needs the dev package, not just zlib1g. If your machine is 32 bit, that should be sufficient; we can modify your site.settings to include 64-bit libraries otherwise.

        • #4523

            Thanks for your reply. It builds now, so that’s progress. I’m not sure if it’s building correctly, though. I had the following problems with the unit tests.

            ERROR: Unused “free” argument specified: core.test

            ERROR: Unable to open file: ./chemical/residue_type_sets/fa_standard/residue_types.txt

          • #4525

              Those errors are indicative of a correct build that’s being run incorrectly. (You may be the first non-developer to even RUN the unit tests…they’re not really meant for the public, but they’re not worth the trouble to remove).

              The second error means you’ve failed to specify a path to the database properly. It will cause the first error under some circumstances.

              The “main” way to run them is from the main mini directory, type:

              test/ -database /path/to/database

              If you are trying to run just one library’s worth, navigate to build/test/a/bunch/of/folders/ until you find, say, core.test.

              Then, core.test -datbase /path/to/database plus other options.

          Viewing 3 reply threads
          • You must be logged in to reply to this topic.