fold and dock protocol not working

Member Site Forums Rosetta 3 Rosetta 3 – Applications fold and dock protocol not working

Viewing 1 reply thread
  • Author
    • #1470

        Hi, Rosetta community

        I’m learning to use the “fold and dock” protocol and I tried the demo(rosetta_tests/integration/tests/fold_and_dock). My output file showed a trimer configuration but the protein was not folded(pdb file attached to this post). Could anyone tell me how to fix this?

        My command script is:


        setenv workdir /Users/ytao/Apps/rosetta/rosetta_tests/integration/tests/fold_and_dock

        cd $workdir

        mpiexec -np 2 $rosettaBin/minirosetta.mpi.macosgccrelease @flags -database $rosettaDB -run:constant_seed -nodelay > log

        My flags are (same as the demo file):

        -run:protocol broker
        -broker:setup input/setup_init.tpb
        -symmetry:symmetry_definition ./input/symm_def_trimer.dat
        -fold_and_dock:rigid_body_cycles 1
        -fold_and_dock:rigid_body_frequency 5
        -run:test_cycles ## Remove to run a real case prediction
        -score:weights score13_env_hb
        -abinitio::recover_low_in_stages 0
        -abinitio:rg_reweight 0.001
        -abinitio:use_filters false
        -packing:ex1:level 1
        -packing:ex2:level 1
        -packing:extrachi_cutoff 0
        -in:file:fasta ./input/2akf_.fasta
        -in:file:frag9 ./input/aa2akf_09_05.200_v1_3
        -in:file:frag3 ./input/aa2akf_03_05.200_v1_3
        -evaluation:rmsd_target input/2akf.pdb
        -evaluation:rmsd_column _
        -nstruct 1
        -out:file:silent_struct_type binary
        -out:path:pdb ./
        -out:file:silent 2akf.out
        -out:level 500

        Never mind. I forgot to remove “-run:test_cycles ## Remove to run a real case prediction” in the flag file. Now it’s running properly.

      • #8130

          I would also point out that -nstruct 1 is never a real case – generally start at 10000 for a small prediction set.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.