Homology modelling applies alignment wrong

Member Site Forums Rosetta 3 Rosetta 3 – Applications Homology modelling applies alignment wrong

Viewing 1 reply thread
  • Author
    • #2256

        Dear all,

        I have been battling with a specific homology modelling for some time (I never had problems before though) and hope that you can help me further. Whichever version of homology modelling I use (3.5 and never hybrid one from the latest release), the sequence of the final model does not correspond to the sequence of the alignment I provid. It appears that a gap very early in the alignment is skipped and all following residues are hence shifted by 2 (only one more gap in ~450 res). For simplicity just the first few residues:


        So, I expect the model to have the two FF/YY and following residues matching, BUT no. The first 5 match and then the sequence is shifted. Any idea what is going on here. It must be something more fundamental since when I start the alignment with the 2 aromatic residues I get the same result.

        Thanks for any help, I am desperate now (after trying for several weeks),


        P.S. I cannot use the robetta server since I have better exp. models available.
        P.S. setup_rosettaCM.py is in an awful state. The newest does not work and the resorting to an old one required lots of patching too. Why cant there be a versio which works?

      • #11135

          I seem to have been able to solve the problem. Apparently I had some wrong numbering in the alignment. Using the following works:


          Obsioulsy(?), I have to substract 1 from the sequence number of the query…


          P.S. Solved for the threaded sequence but unsolved for the state of setup_rosettaCM.py …

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.