How to eliminate “NUL”s when scoring PDBs?

Member Site Forums Rosetta 3 Rosetta 3 – Applications How to eliminate “NUL”s when scoring PDBs?

Viewing 1 reply thread
  • Author
    • #2033

        Dear friends,
        Can I ask how to eliminate “NUL”s when scoring PDBs? When I want to score PDB files, I have tried

        1) -s /mnt/hgfs/test/name.pdb
        2) -s /mnt/hgfs/test/*.pdb # for all the PDB files in the “test” folder
        3) -l /mnt/hgfs/test/list.txt

        These three methods all work fine if only one structure is scored. However, it always generates “NUL”s when two or more PDBs are scored. Sometimes it works fine again even for 100 files but sometimes “NUL”s come back again. I am so frustrating about it and I end up scoring the PDB one by one.

        The attachment is an example for the NUL document. I would appreciate it if this can be solved.

        By the way, I install Rosetta on Ubuntu, and the Ubuntu is on VMwarePlayer.

        Thank you very much.

        Yours sincerely

      • #10450

          Are the NULs always a the start of the file, or do they sometimes show up in the middle? Do the NULs happen randomly, or does the same inputs consistently give you NULs? Do the NULs happen if you run from a completely new directory, or only if you’re running in a directory you’ve run before? Are you writing to a Linux-formatted disk, or is this a Windows disk you’ve mounted as readable within Linux?

          If you could find a set of conditions with a few PDBs which regularly gives you the error and post them here, along with the exact command you’re running and the version of Rosetta you’re running with, then we may be able to better debug things. (e.g. I’ll try and run things locally, and see if I get the same error.)

        • #10454

            Hi R Moretti,
            Your hint is indeed very helpful! Yes, I think it is the problem of “Windows disk mounted within Linux” that causes this problem.

            After geting “NUL” again in the /mnt/hgfs/ path, I tried Linux-formatted disk (i.e. within “home” directory) of Ubuntu. Wow, all the “NUL” disappeared even for 100 structures! I tried again, yes, no “NUL” any more!

            I am so happy now. :)

            Yours sincerely

        Viewing 1 reply thread
        • You must be logged in to reply to this topic.