installation problem on ubuntu 9.04

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install installation problem on ubuntu 9.04

Viewing 3 reply threads
  • Author
    • #974

        i have been trying to install rosetta on ubuntu 9.04 but has some problems.
        the few last lines appear as follows

        sh: o: not found
        sh: o: not found
        o build/src/release/linux/2.6/32/x86/gcc/apps/benchmark/benchmark.o -c -std=c++98 -pipe -ffor-scope -W -Wall -pedantic -Wno-long-long -malign-double -march=pentium4 -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -DNDEBUG -Isrc -Iexternal/include -Isrc/platform/linux/32/gcc -Isrc/platform/linux/32 -Isrc/platform/linux -Iexternal/boost_1_38_0 -I/usr/local/include -I/usr/include src/apps/benchmark/
        sh: o: not found
        gcc -o build/src/release/linux/2.6/32/x86/gcc/ -shared -Llib -Lexternal/lib -Lbuild/src/release/linux/2.6/32/x86/gcc -Lsrc -L/usr/local/lib -L/usr/lib -lprotocols -lcore -lnumeric -lutility -lObjexxFCL -lz
        o build/src/release/linux/2.6/32/x86/gcc/apps/public/scenarios/ca_to_allatom.o -c -std=c++98 -pipe -ffor-scope -W -Wall -pedantic -Wno-long-long -malign-double -march=pentium4 -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -DNDEBUG -Isrc -Iexternal/include -Isrc/platform/linux/32/gcc -Isrc/platform/linux/32 -Isrc/platform/linux -Iexternal/boost_1_38_0 -I/usr/local/include -I/usr/include src/apps/public/scenarios/
        sh: o: not found
        o build/src/release/linux/2.6/32/x86/gcc/apps/public/cluster.o -c -std=c++98 -pipe -ffor-scope -W -Wall -pedantic -Wno-long-long -malign-double -march=pentium4 -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -DNDEBUG -Isrc -Iexternal/include -Isrc/platform/linux/32/gcc -Isrc/platform/linux/32 -Isrc/platform/linux -Iexternal/boost_1_38_0 -I/usr/local/include -I/usr/include src/apps/public/
        /usr/bin/ld: cannot find -lprotocols
        collect2: ld returned 1 exit status
        sh: o: not found
        scons: *** [build/src/release/linux/2.6/32/x86/gcc/] Error 1
        scons: building terminated because of errors.

        can any one please guide me how to overcome such a problem. i have attached the error file with this mail.

      • #5848

          The o: command not solved bug is due to SCons failing to find your compiler. This was how another user got it fixed:

          We can explore other methods if that post doesn’t work.

        • #5852

            i have tried the method suggested but still the error message is same and we failed to install rosetta.
            in my opinion the issues are as follows:

            1. svn: Currently, subversion-1.2.XXX is proposed version for Ubuntu 9.04 as svn. But there was no way to get subversion-1.2.XXX. what is minimum version of svn for Ubuntu 9.04 or rosetta 3.

            2. g++: From Ubuntu’s archive site for S/W, there was no g++ for ver. 4.3 and for g++-4.4 or later version have error with Ubuntu 9.04 (or JUST for our linux server) due to compatibility or dependency problems. which g++ is required to compile?

            3. in one of the mails “/usr/bin/ld: cannot find -lz” but in our case “/usr/bin/ld: cannot find -lprotocols”. what is this
            “-lprotocols” and any solution for this?

            Please reply , this is surely testing my patience!!!!!

          • #5853

              SVN: SVN is not necessary and not recommended. SVN is the software the developers use for version control; the releases still contain hooks into SVN because we fail to remove them, but SVN’s absence will only cause an error message about svn not found and prevent the developer-only -run:version flag from working; it won’t affect the compiled code.

              lprotocols: protocols is one of the Rosetta libraries that SCons is supposed to be building. Apparently it is failing to do so (probably because it can’t find GCC to build it with).

              G++/gcc: We do not have a complete list of what versions and sub-versions work with which OSes and under which phases of the moon. Generally, version-specific issues show up as “internal compiler errors” midway through compilation (not the sort of errors you have mentioned), and those can usually be bypassed by lowering the -finline-limit flag argument. I use gcc 4.3.2 on ubuntu 8.04 and 4.4.5 on 10.10 with no problems.

              If your problem is still “o: command not found” messages, the problem is that SCons isn’t finding gcc/g++. It is attempting to issue commands that look like g++ -o build/src/release/linux/2.6/64/x86/gcc/pr... . If it can’t find g++, then that part of the command is truncated and it issues a nonsense command starting with o. So, the question is, why can’t SCons find g++? You can experiment with “which g++” to see where your computer thinks g++ is, then try to get SCons to find that. You may have luck with explicit choice of compiler version with “cxx_ver=#.#” on the scons command line. You may be able to copy tools/build/site.settings.topsail to tools/build/site.settings; the extra settings in that file give SCons extra pathing locations.

            • #5871

                hi smlewis

                thanks for the kind help we resolved the problem

            Viewing 3 reply threads
            • You must be logged in to reply to this topic.