libdevel not found while running Rosetta using mpi

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install libdevel not found while running Rosetta using mpi

Viewing 1 reply thread
  • Author
    • #1689

        Hello Rosetta experts,
        I am very new to Rosetta and am trying to compile Rosetta3.4 (tried even Rosetta3.5) on a linux cluster with the following command:
        ./ bin mode=release extras=mpi -j 12
        The installation appears to have finished fine though when I try to run a job using mpirun it gives me the following error:
        error while loading shared libraries: cannot open shared object file: No such file or directory.
        From this thread, it appears to me that Rosetta should not ask for library.
        Thank you very much in advance for your help.

      • #9314

          Does the mpi process trying to run Rosetta, and the machine on which Rosetta is running, have read access to the directory where Rosetta lives? I think this may be a permissions issue – the MPI client machines can’t

          You can try the statically linked build (extras=mpi,static), or try fixing the permissions/file visibility?

          Did you try MOVING the Rosetta executable from the place it was compiled onto another machine? That’s a big no-no (unless using the static build).

          If you use the non-mpi build does it work? You can try a quick job on the head node (and just kill it after 20 seconds), which will give plenty of time for this startup error to occur.

        • #9800

            Thank you so much ‘smlewis’ for your reply. I solved the problem. This was the absence of proper library path!

            I just defined the path LD_LIBRARY_PATH in my .sh script while submitting the job on our cluster and this solved my problem.

            export LD_LIBRARY_PATH=/path/with/mpi/binary/SymDock.mpi.linuxgccrelease:$LD_LIBRARY_PATH

            Hope this helps anyone who encounters similar problem.


        Viewing 1 reply thread
        • You must be logged in to reply to this topic.