Member Site Forums PyRosetta PyRosetta – Build/Install

Viewing 1 reply thread
  • Author
    • #2053

        I have downloaded PyRosetta (64-bit, Scientific/Red-Hat linux) for a Fedora 18 OS. I have on this machine python2.7 (64-bit) and a in my /usr/lib64 directory. When I run I get:

        [steve@steve1 PyRosetta]$ ./

        WARNING: IPython History requires SQLite, your history will not be saved

        WARNING: Readline services not available or not loaded.WARNING: The auto-indent feature requires the readline libraryPython 2.7.8 (default, Nov 3 2014, 14:03:48)
Type “copyright”, “credits” or “license” for more information.
        IPython 0.13.1 — An enhanced Interactive Python.
? -> Introduction and overview of IPython’s features.
%quickref -> Quick reference.
help -> Python’s own help system.
object? -> Details about ‘object’, use ‘object??’ for extra details.

        In [1]: from rosetta import *
ImportError Traceback (most recent call last)
 in ()
—-> 1 from rosetta import *
        /usr/local/bin/PyRosetta.ScientificLinux-r56316.64Bit/rosetta/ in
30 # Double-checked right order…
—> 31 import utility
32 import utility.excn
        /usr/local/bin/PyRosetta.ScientificLinux-r56316.64Bit/rosetta/utility/ in
—-> 1 from __utility_all_at_once_ import *
        ImportError: cannot open shared object file: No such file or directory
        In [2]:

        I do not have “” on my machine….What is the solution to this?? I don’t understand why it needs libpython2.6, when I am running python2.7..Would a solution be to install I believe this is not so easy???
        Any comments would be welcomed.
        Thanks, Steve

      • #10533

          In order to use this version of PyRosetta you need to install python-2.6 and it python shared library. There is no need to replace default system python (if thats not desirable), just perform side-install of Python-2.6 and start PyRosetta scripts with ‘python2.6 ‘ instead of just python.

        • #10538

            Thanks for your response, Sergey

            I have install python-2.6.8, but I still get the same error message that “” is not found..So, this package must not come with the python-2.6.8. I then tried to rpm python-libs02.6-7fcll.s390x.rpm; however, the error message said I was missing several dependencies…Is there a PyRosetta binary that can use python 2.7? I’m not sure where to go form here.

          • #10539

              OK…I finally reinstalled python2.6 and found the “” and moved it to the location in which was looking…But, now, I am getting a “Undefined Symbol PyUnicodeUCS4_FromEncodeObject”. I found on rosettacommons where someone had a similar situation with a 32-bit machine and so, they re-installed python2.6 with “enabled-unicode=ucs2”..I will use a “4” instead of a “2”..I hope this works..

            • #10541

                I did the “enabled-unicode=ucs4” so, now this error is gone; however, then I got a “import error: no bz2 module” and so, I downloaded this from a site as bz2.pyc. But now my import error reads that it (python2.6) cannot find bz2.pyd!!
                Would it be better to instal PIP and use it to instal python2.6???? Is my problem strictly my python2.6 install???

              • #10556

                  Yes, it probably is strictly python2.6. I have had many issues trying to build alternate pythons for PyRosetta or for numpy/scipy. I’ve bricked my Mac trying to do this as well. Is this a cluster you are using? pyc files are compiled python files. They are of no use to you. I’m not sure what .pyd is, but you should use pip to install bz2 as you suggested and maybe it will work.

                • #10560

                    .pyd files are dll files (shared libraries for the Windows platform) for Python. An error for missing bz2.pyd definitely means you need to install the bz2 package for your Python installation.

                Viewing 1 reply thread
                • You must be logged in to reply to this topic.