Member Site Forums Rosetta 3 Rosetta 3 – General loop modeling

Viewing 1 reply thread
  • Author
    • #1700

        Hi everyone, i am getting errors in loop modeling, this might be very basic, but i could not able to understand these.

        1) is showing some error, like

        line 23, in set_loop_from_string
        self.start = int(loop_array[1])
        IndexError: list index out of range

        I have only one loop in loop file.

        2) when i run loopmodel.linuxgccrelease for each line it says

        ERROR: Illegal value for integer option -loops:frag_sizes specified: 1
        ERROR: Illegal value specified for option -loops:refine
        ERROR: Illegal value specified for option -loops:remodel : quick_ccd

        @flag i used-

        -nstruct 100 #number of models to build. 1000 recommended for production runs.
        -loops:input_pdb ./A/4ACT_no_loops.pdb #starting pdb with loops to rebuild
        -loops:loop_file ./A/4ACT.loops #loop file
        -loops:relax fastrelax #does a minimization of the structure in the torsion space
        -loops:extended #force phi-psi angles to be set to 180 degrees independent of loop input file (recommended for production runs)
        -loops:frag_sizes 9 3 1
        -loops:frag_files ./A/aa4ACT09_05.200_v1_3 ./A/aa4ACT03_05.200_v1_3 none
        -loops:refine refine_kic
        -out:file:silent_struct_type binary #output file type
        -out:file:silent ./A/4ACT_ccd_loops.out #output file name
        -out:file:fullatom #output file will be fullatom
        -database ./rosetta_database/

        I checked all the path, its perfect.
        Thank you in advance.

      • #9228

          I’m not quite sure what’s going on with 1). That’s not line 23 in any of the versions of the script that I can see. (It’s line 27 of rosetta_tools/protein_tools/rosettautil/rosetta/ ) There is something corrupted about your version of your scripts. In the normal version of the scripts, you wouldn’t get this error, instead you’d be prompted with the error message “loop lines must be in this form: LOOP start end cutpoint skip extend”

          For 2) my guess is that you have non-printing character issues with your flag files. One possibility is that you edited your flag file on Windows (which has CR+LF line endings) but ran Rosetta on Mac or Linux (which has LF line endings). The extra CR on the line is being taken to be part of the option.

          If you’re on unix, I believe the following command will help:

          tr -cd ‘111240-176’ < flags > flags_clean

          This will remove everything in an ASCII file that’s not a space, tab, (unix) line ending or standard printable character.

        • #9231

            I dont know, i ts showing this error , i have attached the :

            mh@hpmh:~/rosetta/rosetta_tools/protein_tools/rosettautil$ ./ 4ACT.loops 4ACT.pdb 4ACT_no_loop.pdb
            Traceback (most recent call last):
            File “./”, line 16, in
            File “/usr/local/lib/python2.7/dist-packages/rosettautil/rosetta/”, line 54, in read
            File “/usr/local/lib/python2.7/dist-packages/rosettautil/rosetta/”, line 23, in set_loop_from_string
            self.start = int(loop_array[1])
            IndexError: list index out of range

          • #9233

              Both things got solved. Earlier i used remove_loop_coords from tutorial folder, when i used it from rosetta tools it worked fine.
              Second issue was also solved by re writing option file manually. Thank you very much.

          Viewing 1 reply thread
          • You must be logged in to reply to this topic.