loop modelling error on Rosetta3.2 or Rosetta3.3

Member Site Forums Rosetta 3 Rosetta 3 – General loop modelling error on Rosetta3.2 or Rosetta3.3

Viewing 1 reply thread
  • Author
    • #1039

        I am trying to remodel the loop giving low-resolution electron density map. I have tried Rosetta3.2 and 3.3 however the job could not complete when I run in mpi mode. Could you have any solution for this?

        The log of error is like this. It is due to mpi.

        output filename: .//outdir_2/S_0003.pdb
        ERROR: Unable to open file: .//outdir_2/S_0003.pdb
        ERROR:: Exit from src/protocols/jobdist/JobDistributors.cc line:727

      • #6078

          That code is still using the old job distributor. It wants you to pre-create (run_directory)/outdir_2 for it to put results in. Rosetta will create the output PDB files but refuses to create the output directory to put it in. I would guess you need outdir_0 through outdir_N, where N is the number of processors in the MPI job.

        • #6079

            Thanks a lot for helpful information.

            Could you tell me how we can get rid of this?

          • #6082

              Exactly. For a loop modeling mpi job, you would need to create one output directory per processor to avoid that independent processes overwrite each others outfiles. The same is true for running jobs in parallel on a cluster.

            • #6080

                Get rid of what? The error? You need to create the output directories it expects manually ahead of time…

              • #6081

                  By the way, in these sorts of situations, some bash (or whatever shell you’re using) knowledge makes life easier.

                  For example, entering something like:

                  for i in {0..31}
                  mkdir outdir_${i}

                  on the bash shell command line is a lot more pleasant than manually creating each directory by itself.

              Viewing 1 reply thread
              • You must be logged in to reply to this topic.