mcm for Docking in Rosetta3.1

Member Site Forums Rosetta 3 Rosetta 3 – General mcm for Docking in Rosetta3.1

Viewing 1 reply thread
  • Author
    • #408


        I recently installed Rosetta3.1. When I tried to run the demo for the Docking application, I received the error message:

        ERROR: Option matching -dock_mcm not found in command line top-level context.

        Since the documentation says that the default dock_mcm is “true”, I tried running docking without the -dock_mcm flag. In that case, the the application runs but includes the warning:

        Warning: Unable to detect database file Dunbrack02.lib.bin.

        I am not sure if these two problems are related. Any ideas?

        Thank you!

      • #4309

          The warnings are unrelated.

          The dock_mcm flag was apparently deprecated in 3.1 and nobody fixed the documentation. dock_mcm is the default behavior (the other options being dock_min and dock_ppk).

          The warning about Dunbrack02.lib.bin is standard the first time you run Rosetta on a new computer. The Dunbrack library is fairly large, so to speed processing Rosetta will rewrite the ASCII database into a binary-encoded database (a serialized object) for faster reloading. You shouldn’t see this error in subsequent runs.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.