Membrane folding – blastpgp error.

Member Site Forums Rosetta 3 Rosetta 3 – General Membrane folding – blastpgp error.

  • This topic has 4 replies, 3 voices, and was last updated 12 years ago by Anonymous.
Viewing 4 reply threads
  • Author
    Posts
    • #1215
      Anonymous

        I know that there have been a number of posts about this problems but none of them post solution to this so hopefully someone can help.

        I am attempting to run_lips.pl with the following command

        /home/eliza/rosetta/rosetta_source/src/apps/public/membrane_abinitio/run_lips.pl eliza.FASTA eliza.span /home/eliza/ncbi/blastpgp /home/eliza/ncbi/nr /home/eliza/rosetta/rosetta_source/src/apps/public/membrane_abinitio/alignblast.pl

        But I get the error….

        Error in alignblast.pl: blast output file eliza.FASTA truncated:
        readline() on closed filehandle MSA at /home/eliza/rosetta/rosetta_
        source/src/apps/public/membrane_abinitio/run_lips.pl line 91.

        This is, I believe, because blastpgp is returning and empty file.

        I downloaded the nr database from
        ftp://ftp.ncbi.nih.gov/blast/db/FASTA/

        and unpacked it to /home/eliza/ncbi/ this gives a single large file called ‘nr’.

        when I run blastpgp directly i do not get an error message but this generates an empty file as well. Clearly there is something wrong with my blastpgp setup and/or nr database.

        I installed blast2 (which includes blastpgp from Ubuntu aptget) and I have also downloaded the executables from the blast legacy files from the ncbi website in case the ubuntu provided version was corrupt in some way but i get the same result with both so i don’t think its that.

        I would be grateful for any help you could give.

        Best wishes

        Chris

      • #6850
        Anonymous

          None of the regulars on this forum know anything about run_lips.pl. I’ve sent this along to the authors of that code, but you may wish to contact them directly in case they don’t reply here. (If you get an answer, we’d appreciate it if you’d echo it here).

        • #6856
          Anonymous

            Thanks for the reply Steven. If I work it out I will indeed put my solution up, but if anyone has any bright ideas I’d be happy to hear them

            Chris

          • #6861
            Anonymous

              Hi Chris,

              This is blast related issue – follow directions at http://www.rosettacommons.org/manuals/archive/rosetta3.3_user_guide/file_fragments.html
              Here is a content of my folder with “nr” database:
              nr nr.00.pin nr.00.ppd nr.00.psq nr.01.pin nr.01.ppd nr.01.psq nr.02.pin nr.02.ppd nr.02.psq nr.03.pin nr.03.ppd nr.03.psq nr.04.pin nr.04.ppd nr.04.psq nr.05.pin nr.05.ppd nr.05.psq
              nr.00.phd nr.00.pnd nr.00.ppi nr.01.phd nr.01.pnd nr.01.ppi nr.02.phd nr.02.pnd nr.02.ppi nr.03.phd nr.03.pnd nr.03.ppi nr.04.phd nr.04.pnd nr.04.ppi nr.05.phd nr.05.pnd nr.05.ppi nrfilt
              nr.00.phi nr.00.pni nr.00.psd nr.01.phi nr.01.pni nr.01.psd nr.02.phi nr.02.pni nr.02.psd nr.03.phi nr.03.pni nr.03.psd nr.04.phi nr.04.pni nr.04.psd nr.05.phi nr.05.pni nr.05.psd nr.pal
              nr.00.phr nr.00.pog nr.00.psi nr.01.phr nr.01.pog nr.01.psi nr.02.phr nr.02.pog nr.02.psi nr.03.phr nr.03.pog nr.03.psi nr.04.phr nr.04.pog nr.04.psi nr.05.phr nr.05.pog nr.05.psi

              Hope it helps.

              Vladimor

            • #7085
              Anonymous

                Thanks Vladimor, your email pointed me in the right direction.

                For those with similar problems in future the database listed in Vladimor’s link is incorrect. Download the nr* files in the ftp://ftp.ncbi.nih.gov/blast/db/

                Upacking these files gives the files that Vladimor talks about.

                I then hit a problem with

                Error in alignblast.pl: blast output file eliza.blast truncated:
                readline() on closed filehandle MSA at /rosetta_source/src/apps/public/membrane_abinitio/run_lips.pl line 91.

                This happened because eliza.blast is not generated.

                Going through run_lips.pl I found the problem here…

                $DB=$NR;
                $blastout=$seq;
                $blastout=~s/fasta/blast/g;

                It should make run_lips aware of the output file location. For some reason this bit doesn’t work (i suspect write permissions errors on my folder but I couldn’t pin it down).

                So my problem was that my output and input files had the same name – so it wasn’t then going on and doing the blast search. By changing this to…

                $DB=$NR;
                #$blastout=$seq;
                $blastout=”$seq.out”;
                #$blastout=~s/fasta/blast/g;

                The output file is no longer the same name and everything works fine.

                I hope that helps someone in the future

                Chris

            Viewing 4 reply threads
            • You must be logged in to reply to this topic.