Minimization Issue: Coarse Graining to All atom modeling

Member Site Forums Rosetta 3 Rosetta 3 – General Minimization Issue: Coarse Graining to All atom modeling

  • This topic has 5 replies, 2 voices, and was last updated 9 years ago by Anonymous.
Viewing 3 reply threads
  • Author
    Posts
    • #2188
      Anonymous

        Hi all,
        I want to get an all atom model of my coarse grained protein structure (after adding all the side chains back). I have been using the repacking algorithm to do so, but unfortunately its not doing the job. The side chains are not packed properly. Can you help me suggesting on how to go from coarse grained protein to get an all atom model for my protein. Is there any minimization protocol that can take care of this. Kindly let me know.

        Thank you.

      • #10987
        Anonymous

          Repacking the protein is the standard way to put the sidechains on after going through centroid mode. Why do you think it’s not working appropriately?

          If you’re looking for a minimization protocol, one possibility is to use the constrained relax protocol. (https://www.rosettacommons.org/docs/wiki/rosetta_basics/preparing-structures#Short-Protocol-%28recommended%29). You would, of course, remove the “-relax:coord_constrain_sidechains” flag, but the running the protocol with just the backbone constraints would pack and minimize the sidechains while keeping the backbone more-or-less in the input conformation.

        • #10988
          Anonymous

            Hi,
            I am attaching my protein files for you to have a look. I have my native protein as “protein.pdb”. I coarse grain it and then perturb my protein backbone a little bit (using PRS, Atilgan et al 2010, Biophysical J). Now I put my side chains back and then I repack it using repacking algorithm from Rosetta. I get my output file as “repacked-protein.pdb”. Now all the other side chains are repacked except the loop region from 73-75. After this I also used relax protocol and obtained “relax-protein.pdb” file. But still its not able to minimize properly in the loop region. Do you have any suggestions on how I can solve this.

            Thank you so much for your help.

          • #10999
            Anonymous

              Thank you so much rmoretti for your suggestions. However, inspite of using the contraints, its not able to minimize as you said it won’t fix bad bond lengths and angles in the backbone. I will try to reduce my perturbation strength and run again and see if it can work then.
              Thank you so much for your help.

            • #10995
              Anonymous

                When you initially said coarse graining, I initially thought of something along the lines of Rosetta’s centroid mode, which abstracts the sidechain positions, but keeps the backbone heavy atoms in physiological relevant positions.

                Looking at repacked-protein.pdb, it looks like your coarse graining method significantly perturbs the backbone coordinates. Repacking only changes the sidechain coordinates – the input backbone conformation will be preserved if you just do repacking.

                Moreover, many protocols in Rosetta work in internal coordinate space by manipulating torsion angles only. They won’t necessarily fix things if you have non-physiological bond lengths and angles. By default relax is like that – it won’t fix bad bond lengths and angles in the backbone. It will only change the backbone torsions.

                My suggestion is to use a slightly different relaxation protocol. The relax application has the ability to do either a “cartesian” or “dualspace” (mixed torsion/cartesian) relax. Both of these will allow backbone bond lengths and angles to optimize to be closer to the “ideal” values. Just add the flag “-relax:dualspace” or “-relax:cartesian” to the relax application commandline to invoke these protocols.

                By the way, you probably want to omit the backbone constraints in these relax runs, as the input backbone coordinates are not what you want. Alternatively, you could keep the backbone constraints on but remove the “-ramp_constraints false” and/or increase the value to -relax:coord_cst_width to allow more movement. (Value of the last is the size of allowable atom movement in Angstroms.)

              • #11002
                Anonymous

                  Sorry, just to clarify: *do not* apply constraints, but *do* add the -dualspace flag. So your commandline would look something like:

                  relax.linuxgccrelease -dualspace -score:weights talaris2013_cart -s your_structure.pdb

                  (The -score:weights talaris2013_cart is needed because it has the extra terms that keep the bond lengths and angles from getting too far from the ideal versions.)

              Viewing 3 reply threads
              • You must be logged in to reply to this topic.