mode=release compile on a mac-pro , seg faults and bus errors

Member Site Forums Rosetta 3 Rosetta 3 – General mode=release compile on a mac-pro , seg faults and bus errors

Viewing 2 reply threads
  • Author
    • #667

        Anyone have suggestions for getting “fast” binaries on a mac pro machine under osx 10.5 ?

        The standard “debug” compilation yields working binaries, the “release” compile yields binaries which product segmentation faults and/or bus errors.

        Any advice appreciated… I’m guessing I’ll have to edit “./tools/build/basic.settings” and start deleting/changing compiler flags, etc.

      • #4613

          You can take a look at this and see if it helps. (I’m repeating this statement without really understanding it – I know nothing about mac compilation).


          Barring that, you are correct, you need to determine which flag in release mode is causing problems and turn it off.

          If ALL release binaries are causing problems, I can at least help you speed up the searching process. You can go into apps.src.settings and comment out (#) every app except one of your choice (I suggest fixbb), then go into protocols.src.settings and comment out pretty much every directory except jd2 and moves. That should leave you with an extremely stripped but still compileable version of just the fixbb app. I think you’ll have to recompile from scratch as you change flags, so this should help a lot with that. (If you use an app other than fixbb, you’ll need to change what’s commented out in protocols.src.settings)

        • #4614

            Thanks for the advice.

            I tried the snow leopard patch (even though this machine is running leopard) — didnt work.

            Starting from the ‘debug’ setup

            I tried changing -O0 to -O1 , -02, -03 and removing the -g -ggdb lines from the ‘debug’ section and changing compilers.

            Removing -g -ggdb lines works, but does not speed things significantly

            changing optimizations level from -O0 (which works) to 1,2 or 3 all cause seg faults and bus errors.

            Tried diff compilers:
            gcc version 4.0.1 (Apple Inc. build 5493)
            gcc version 4.2.1 (Apple Inc. build 5574)

            both fail with any optimizations above -O0

            Seems I’ll have to upgrade to snow leopard and hope other software on the machine does not go south.

        Viewing 2 reply threads
        • You must be logged in to reply to this topic.