multiprocessor build not working

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install multiprocessor build not working

  • This topic has 5 replies, 2 voices, and was last updated 9 years ago by Anonymous.
Viewing 5 reply threads
  • Author
    Posts
    • #2195
      Anonymous

        (While I have 30+ years in tech, I am not a unix person)

        I have a Dell Precision with Dual Zeon processors with a total of 16 cores. I was able to successfully build Rosetta, however, when I tried to do it again with the “extras=mpi” flag I got an error;

        “mpiCC: Not Found”

        I saw another person post on this issue, but not all of the steps to resolution were included and the people involved were Unix/Linux savy. For example, when I typed “which mpiCC” there was no response from the console. Then I read in the documentation that site.setting.topflight had to be “copied to” site.settings”, but I don’t see a file simply named “site.settings” in the folder. (site.settings., but none simply named site.settings)

        Thank you in advance!

        -Scott

      • #11008
        Anonymous

          “mpiCC: Not Found” and “when I typed “which mpiCC” there was no response from the console” tell me that MPI is simply not installed on your computer. It’s never installed by default. You didn’t specify your OS, but Google will know how to help you install MPI for most OSes. On mine it would be ‘sudo apt-get install [name of some mpi package]’, for example.

          site.settings doesn’t exist until you make it. You literally copy some specific site’s settings file to the generically named site.settings file. “cp site.settings.topflight site.settings”. Rosetta only sees site.settings, all those other ones are folk’s versions of site.settings, discriminated by name so they can co-exist.

        • #11009
          Anonymous

            Thank you very much. My apologies for leaving complete details on my scenario. I am running the latest Ubuntu release.

            I will go ahead and create the file as you described. I wish they would have noted that in the docs… or at least created the file and just put comments inside describing the situation. Ahh, well…

            The Google search is a bit annoying though as even with search qualifiers I keep getting pages about people using mpiCC on something called the Message Passing Interface. Oiy :)

          • #11010
            Anonymous

              The one page that I found that seemed to have the info I needed said to use:

              “sudo apt-get install zlib1g-dev”

              So I executed that after copying the settings file (sorry, it was “topsail” not “topflight”). Then I tried the build again and this is what I got back:

              “~/Rosetta/main/source$ ./scons.py -j16 mode=release bin extras=mpi
              scons: Reading SConscript files …
              Traceback (most recent call last):
              File “/home/starone/Rosetta/main/source/SConstruct”, line 150, in main
              build = SConscript(“tools/build/setup.py”)
              File “/home/starone/Rosetta/main/source/external/scons-local/scons-local-2.0.1/SCons/Script/SConscript.py”, line 614, in __call__
              return method(*args, **kw)
              File “/home/starone/Rosetta/main/source/external/scons-local/scons-local-2.0.1/SCons/Script/SConscript.py”, line 551, in SConscript
              return _SConscript(self.fs, *files, **subst_kw)
              File “/home/starone/Rosetta/main/source/external/scons-local/scons-local-2.0.1/SCons/Script/SConscript.py”, line 260, in _SConscript
              exec _file_ in call_stack[-1].globals
              File “/home/starone/Rosetta/main/source/tools/build/setup.py”, line 421, in
              build = setup()
              File “/home/starone/Rosetta/main/source/tools/build/setup.py”, line 413, in setup
              build.settings = setup_build_settings(build.options)
              File “/home/starone/Rosetta/main/source/tools/build/setup.py”, line 210, in setup_build_settings
              site = Settings.load(“site.settings”, “settings”)
              File “/home/starone/Rosetta/main/source/tools/build/settings.py”, line 86, in load
              execfile(file, settings)
              File “site.settings”, line 27, in

              File “/usr/lib/python2.7/UserDict.py”, line 23, in __getitem__
              raise KeyError(key)
              KeyError: ‘INCLUDE’
              scons: done reading SConscript files.
              scons: Building targets …
              scons: `bin’ is up to date.
              scons: done building targets.”

              Doesn’t look all to conclusive to me… ;)

            • #11011
              Anonymous

                Update*:

                I think I found the correct package by using the Ubuntu Software Center then running :

                “sudo apt-get install mpi-default-dev”

                Now when I submit “which mpiCC” I get:

                “/usr/bin/mpiCC”

                Oddly enough, when I ran the compile, the exact same output resulted and I don’t see any files in the bin directory with “.mpi” included in the name.

                Maybe this “topsail” settings file is the wrong one? Examining its contents, I don’t see anything that looks significant.

              • #11012
                Anonymous

                  * Update:

                  Following the instructions in this post (linked from the docs) seems to have done the trick.

                  https://www.rosettacommons.org/node/3931

              Viewing 5 reply threads
              • You must be logged in to reply to this topic.