Parse error while reading in XML file in ROSETTA Scripts

Member Site Forums Rosetta 3 Rosetta 3 – Applications Parse error while reading in XML file in ROSETTA Scripts

Viewing 2 reply threads
  • Author
    • #1985

        Hello everybody,

        I wanted to run a ROSETTA Scripts script to design a portion of a protein interface. But I struggle with an unexpected error, which appears to occur during reading in the XML protocol. I started the application with the following command line:

        /software/linuxsoft/rosetta-3.5/rosetta_source/bin/rosetta_scripts.linuxgccrelease -database /homes/rweisse/xprog/rosetta_database/ -s dist_fill.B99990001_ros.pdb -nstruct 100 -jd2:ntrials 20 -out:pdb_gz true -parser:protocol dist_fill.B99990001_ros.script.xml -overwrite -constrain_relax_to_start_coords -constraints:cst_fa_file dist_fill.B99990001_ros_sc.cst -relax:script always_constrained_relax_script -score:weights score12 -no_optH false -skip_set_reasonable_fold_tree -no_his_his_pairE -fa_max_dis 6.0 -options:user -hbond_params OLF_params_4 -lj_hbond_hdis 1.75 -lj_hbond_OH_donor_dis 2.6

        The error is as following:

        protocols.jd2.DockDesignParser: dock_design_filename=/homes/rweisse/Dokumente/P450/linker_rosetta/ROSETTA/dist_fill.B99990001_ros/dist_fill.B99990001_ros.script.xml
        Error: ERROR: Exception caught by JobDistributor while trying to get pose from job dist_fill.B99990001_ros_0001Tag::read – parse error, printing backtrace.

        Tag::read – parse error – file:istream line:1 column:1 –
        Tag::read – parse error – file:istream line:1 column:1 – ^

        Error: Treating failure as bad input; canceling similar jobs
        protocols.jd2.FileSystemJobDistributor: job failed, reporting bad input; other jobs of same input will be canceled: dist_fill.B99990001_ros_0001
        protocols.jd2.JobDistributor: no more batches to process…
        protocols.jd2.JobDistributor: 100 jobs considered, 1 jobs attempted in 7 seconds

        I would really appreciate some suggestions to get my XML file (attached) to run.


      • #10245

          That parse error is typically due to the fact that you have mismatched tags – Rosetta tries to figure out where exactly the error occurs, but sometimes it can’t do that well, so it just reports the first ROSETTASCRIPTS tag as an error.

          In your case you have several issues. The first is in the FastRelax tag, where you don’t have a tag to close the FastRelax tag block. (Also, you seem to have a spurious RestrictToRepacking in the FastRelax tag – if you want to use a RestrictToRepacking operation, you have to create a new one in the TASKOPERATIONS block, and then use the name= from that tag in the mover tag, rather than usign “RestrictToRepacking” itself. See how cmdline is used for an example. Also, it’s best to avoid spaces in the comma separated list, as that can affect parsing.)

          The second issue is in the MinMover tag block. You have the MoveMap subtags, but in the opening MinMover tag you’ve already closed out the tag with the “/>” at the end. Remove the slash, and then the MinMover tag will remain open until it encounters the tag.

          Another thing I should point out is that certain options you’re passing on the commandline aren’t necessarily going to be honored. Specifically the “-constrain_relax_to_start_coords -relax:script always_constrained_relax_script” are specific to the relax application, and aren’t observed by the FastRelax mover in RosettaScripts. Instead you want to use the AtomCoordinateCstMover ( to add the same type of constraints to the pose. You would then want to remove the constraints from the pose afterward with the ClearConstraintsMover, so they won’t be present during the packing and minimization steps. For the “-constraints:cst_fa_file dist_fill.B99990001_ros_sc.cst ” you’ll want to use the ConstraintSetMover to add the constraints, although if the constraints are simply externally generated sidechain coordinate constraints, the AtomCoordinateCstMover has the ability to add them automatically.

        • #10269

            Thank you very much.

            Finally, it worked.

          • #13638

              Dear Dr. rmoretti

              I have same problem with reading XML file. Could you do me a favor and look at my XML. Please find it in attachment.

            • #13642

                I’m not seeing a XML parsing error with your file on Rosetta 3.7.  I *do* have an issue with Rosetta 3.8, but it’s a slightly different issue than the above. 

                Between Rosetta 3.7 and 3.8 we changed the format of the RosettaScripts XML slightly, to make it conform to the official XML format. This means that older XML scripts won’t work as-is. The script you have is in the older format.

                But that’s not a big deal, as we also provide a converter script. Just run something like 

                Rosetta/tools/xsd_xrw/ --input input_protocol_old.xml --output input_protocol_new.xml

                If you don’t care about keeping around the old-format version, the script even works properly if you specify the same name for input and output.

              • #13650

                  Thank you very much. It works now.

              Viewing 2 reply threads
              • You must be logged in to reply to this topic.