Please help – mpiCC Error

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install Please help – mpiCC Error

Viewing 3 reply threads
  • Author
    • #1659

        I’m trying to install mpi version of rosetta-3.4 in cluster.
        I got the error when i did “scons bin mode=release extras=mpi (with and without cxx=icc) “, mpiCC : Command not found

        In the cluster there is mpicc, mpicxx. There is NO mpic++, mpiCC.

        What should i do now?

        How do i install mpiCC without administrative previleges?

        Please help me:)

        Note:- I’m from non cs background.

      • #9073

          The first thing to try with pathing problems is to copy tools/build/site.settings.topsail into (or over) tools/build/site.settings. Open this file and you’ll see:

          “program_path” : os.environ[“PATH”].split(“:”),
          “include_path” : os.environ[“INCLUDE”].split(“:”),
          “library_path” : os.environ[“LD_LIBRARY_PATH”].split(“:”),

          The first line is what you need, it will make scons more aggressive in finding mpiCC. (If you get an include-related error, delete that include_path line).

          If that doesn’t work, leaving this trick in place, try (in your home directory) making a symlink between mpiCC and mpicxx, and making sure your home directory is in your $PATH environment variable. This means your system will treat mpicxx as mpiCC (they’re supposed to be the same thing anyway) and hopefully work.

        • #9075

            What machine are you on?

            This looks like the same error I had when first trying to compile on lonestar and stampede on the TACC systems. The issue was that TACC is configured to use Intel compilers with MPI libraries, and the way they are linked together is somewhat different than you would do with gcc. I worked out the settings and put them in the files site.settings.tacc.lonestar and site.settings.tacc.stampede (in main/tools/build/). You might try copying one of these to site.settings and seeing if that fixes the problem.

            If that works, please report back with the machine name so others know.

            Good luck!


          • #9084

              Thanks Guys,
              I solved the Problem.

              This is what i did:

              => cd rosetta-3.4/rosetta_source/tools/build/
              => vi basic.settings
              => In the file i searched for “mpiCC” and replaced with “mpicxx” (Found at two places)
              => Then when i gave scons bin mode=release extras=mpi (with and without cxx=icc) it gave some error: mpicxx -V-4.3 …
              => Then i searched for “-V-4.3” and deleted it. (Found at two places)/
              => Then when i gave scons bin mode=release extras=mpi it complied successfully.
              => I tested the binaries with relax and it ran successfully.

              Note:- During compiling it gave many warnings like:

              mpicxx -o build/src/release/linux/2.6/64/x86/gcc/4.3/mpi/protocols/simple_moves/MinMover.os -c -isystem external/boost_1_46_1/boost/ -isystem external/boost_1_46_1/boost/ -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -fPIC -DNDEBUG -DUSEMPI -Isrc -Iexternal/include -Isrc/platform/linux/64/gcc/4.3 -Isrc/platform/linux/64/gcc -Isrc/platform/linux/64 -Isrc/platform/linux -Iexternal/boost_1_46_1 -Iexternal/dbio -I/usr/include -I/usr/local/include src/protocols/simple_moves/
              src/protocols/simple_moves/MinMover.hh: In constructor ‘protocols::simple_moves::MinMover::MinMover(core::kinematics::MoveMapOP, core::scoring::ScoreFunctionCOP, const std::string&, core::Real, bool, bool, bool)’:
              src/protocols/simple_moves/MinMover.hh:166: warning: ‘protocols::simple_moves::MinMover::cartesian_’ will be initialized after
              src/protocols/simple_moves/MinMover.hh:165: warning: ‘core::Real protocols::simple_moves::MinMover::threshold_’
              src/protocols/simple_moves/ warning: when initialized here

              mpicxx -o build/src/release/linux/2.6/64/x86/gcc/4.3/mpi/protocols/simple_moves/MissingDensityToJumpMover.os -c -isystem external/boost_1_46_1/boost/ -isystem external/boost_1_46_1/boost/ -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -fPIC -DNDEBUG -DUSEMPI -Isrc -Iexternal/include -Isrc/platform/linux/64/gcc/4.3 -Isrc/platform/linux/64/gcc -Isrc/platform/linux/64 -Isrc/platform/linux -Iexternal/boost_1_46_1 -Iexternal/dbio -I/usr/include -I/usr/local/include src/protocols/simple_moves/
              In file included from src/protocols/simple_moves/
              src/core/kinematics/FoldTree.hh: In member function ‘bool core::kinematics::FoldTree::jump_exists(int, int) const’:
              src/core/kinematics/FoldTree.hh:731: warning: comparison between signed and unsigned integer expressions
              src/core/kinematics/FoldTree.hh: In member function ‘core::Size core::kinematics::FoldTree::jump_nr(core::Size, core::Size) const’:
              src/core/kinematics/FoldTree.hh:1051: warning: comparison between signed and unsigned integer expressions

              Also “comparion between signed and unsigned integer…” warning also came.

            • #9085

                glad it worked! that was essentially what the site.settings file replaces too. there are also flags in the site.settings.tacc.* files that turn off a few of the most annoying warnings.

            Viewing 3 reply threads
            • You must be logged in to reply to this topic.