Problem of installing PyRosetta on Mac Lion

Member Site Forums PyRosetta PyRosetta – Build/Install Problem of installing PyRosetta on Mac Lion

Viewing 4 reply threads
  • Author
    • #1629


        I am currently a new user on both Rosetta and Python. I have a Mac and here are the information:

        Mac Duo Core
        OS 10.7.5
        Python 2.6.2
        GCC 4.0.1
        Xcode installed

        I was trying to install PyRosetta according to the instruction on the website. However, when I get to the step

        import rosetta; rosetta.init().

        I got the following error message:

        ImportError: dlopen(rosetta/utility/, 2): no suitable image found. Did find:
        rosetta/utility/ mach-o, but wrong architecture

        Could anyone show me how I should solve the problem? I have only very little background on linux .

        Thank you ver much


      • #8982

          Hi Sing,

          ‘wrong architecture’ usually means your mismatching the 64 bit PyRosetta version with a 32 bit, x86, cpu. First, double check your cpu. If it is 64 bit, there may be some other strange problem we might have to ask Sergey about. If it’s 32, you may need to try one of the older builds as the newest binaries are only 64 bit.


        • #8984

            Sing, could you please check your Python version? Just run ‘which python && python’ and see what output you get. I think you might be running 32bit version of Python. For Mac OS Lion you should see something like this:

            Python 2.7.1 (r271:86832, Jul 31 2011, 19:30:53)
            [GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on darwin
            Type “help”, “copyright”, “credits” or “license” for more information.

          • #8997

              Hey Sing,

              That says that your hardware supports 64 bit mode. Not necessarily what mode Mac OS X is running in.

              Check this page for machines that boot default 32 bit kernel vs 64 bit:

              Then, try holding in 6 + 4 when restarting the mac.

              Try and see if it will work. If not, than it is most likely an issue with python.

            • #9003


                The 2.6 python is old 32 version. I am guessing that sometime in the past you have changed your default version from 2.7 to 2.6. So what you can do is ether:

                – use python2.7 executable to run PyRosetta (just type ‘python2.7’ in command line instead of ‘python’) or

                – you can switch your default python version back to 2.7 (Googling for it show: )

                Regarding the installing custom Python – that will not work, you have to use Apple build in Python for PyRosetta to work.

                Hope that helps,

              • #8983

                  Thanks Jadolfbr,

                  I tried to run sysctl and it said it is 64 bit computer

                  Therefore, I am wondering if there is any weird problem going on.


                • #8991

                    Thank you for replying, Sergey!

                    Here is the information I got:

                    python 2.6.2 (r262:71600,, Apr 16 2009, 09:17:39)
                    [GCC 4.0.1 (Apple Computer, Inc. Build 5250)]

                    Should I install a new python then?

                  • #8995

                      Be careful doing this. I have bricked or nearly-bricked my mac doing this a few years ago.
                      Just out of curiosity – which PyRosetta version do you have? It should have a number associated with it – ex for my ubuntu machine- PyRosetta.Ubuntu-12.04LTS-r55422.64Bit



                      Can you check to make sure your running mac in 64 bit mode? I know 10.6 could boot in 32 bit mode, and 10.7 may be the same. There was a key you had to hold down to get it to work during startup.


                    • #8996

                        Hi jadolfbr,

                        I am trying to install PyRosetta.MacOSX.Lion-r55421.64Bit.tar

                        I was using this command:

                        sysctl hw.optional.x86_64

                        and it prints 1 which I assume it is 64 bit mode

                        Thank you!!


                      • #8999

                          Thanks jadolfbr.

                          However, I cannot get it work at all. I looked up /usr/local/bin and I found that I have every version of python there. from 2.6 to 3.3. would it be the problem?


                        • #9004

                            Thank you Sergey!!

                            I tried python2.7 also. but the error message I got was:

                            Fatal Python error: Interpreter not initialized (version mismatch?)

                            Any suggestions are always welcome and appreciated~ I’m desperate now

                        Viewing 4 reply threads
                        • You must be logged in to reply to this topic.