Problem readin .ccp4 map file

Member Site Forums Rosetta 3 Rosetta 3 – Applications Problem readin .ccp4 map file

Viewing 3 reply threads
  • Author
    • #896

        Hi all,
        I have bin trying to run the electron_density/molecular_replacement demo at step 4 and I get the following error. There is nothing wrong with the ccp4 map file (opens fine in other programs)but it appears to be looking for a MRC format map. How do I get the program to accept the ccp4 map?

        core.scoring.electron_density.ElectronDensity: Loading Density Map
        core.scoring.electron_density.ElectronDensity: [ ERROR ] Error opening MRC map MR.1_2mFo-DFc.ccp4. Not loading map.
        core.scoring.electron_density.ElectronDensity: [ ERROR ] Error loading density map named ‘MR.1_2mFo-DFc.ccp4’

      • #5536


          The error message is a bit unclear: Rosetta reads both MRC and CCP4 format density maps (it uses the header to determine the type).

          Based on the error message, it looks like Rosetta is not able to find the map file. If you give the complete path to the mapfile with -edensity:mapfile, does that help?

          -Frank DiMaio

        • #5537

            I tried giving it the complete path and also putting it in the working directory for both the demo and my own files and both fail with the same error. Also it does find the template file which is in the same directory. I am confused as to why it says “Error opening MRC map” instead of ccp4. The script is:


            mkdir relaxes
            cd relaxes

            -database /usr/local/rosetta/rosetta_database
            -MR::mode cm
            -in::file::extended_pose 1
            -in::file::fasta ../inputs/1crb.fasta
            -in::file::alignment ../templates/2qo4.ali
            -in::file::template_pdb ../phaser/2qo4_mr.PHASER.1.pdb
            -edensity:mapreso 3.0
            -edensity:grid_spacing 1.5
            -edensity:mapfile ../phaser/2qo4_mr.PHASER.1_2mFo-DFc.ccp4
            -edensity::sliding_window_wt 1.0
            -edensity::sliding_window 5
            -relax::default_repeats 2
            -relax::jump_move true
            -cm::aln_format grishin
            -MR::max_gaplength_to_model 0
            -nstruct 1
            -ignore_unrecognized_res -overwrite -out:prefix nogaps_

          • #5539

              The permissions were fine but the problem was fixed by giving Rosetta the full path to all the files that needed to be input. This was needed even if all the files were in the working directory.


            • #5538


                The “Error opening MRC map” is a generic message if the map opening fails; Rosetta hasn’t read the header yet to determine what type of file it is (failures while reading the map would give additional information). Also I believe the map reading happens before the template file is read, so that would fail first.

                Do you have write permission in the folder you’re running in? Can you try giving Rosetta the full path rather than a relative path to the input files?


            Viewing 3 reply threads
            • You must be logged in to reply to this topic.