Problem running make_fragments.pl script

Member Site Forums Rosetta 3 Rosetta 3 – General Problem running make_fragments.pl script

  • This topic has 0 replies, 1 voice, and was last updated 14 years ago by Anonymous.
Viewing 0 reply threads
  • Author
    Posts
    • #585
      Anonymous

        Hi ALL,

        I am trying to run the make_fragments.pl program to generate fragment files to be used in structure prediction. In it i am using PSI-PRED and PROF as the ss prediction tools. However while executing the script I am getting the following error:


        Sequence: NLYIQWLKDGGPSSGRPPPS
        running prof.
        cmd is: /md1/anirbang/Software/ROSETTA/rosetta_fragments/nnmake/run_prof.py 1l2y_.fasta ss_blast 1l2y_.prof_rdb
        psiblast_file= ss_blast round: 1 nseq: 0 max_e: 0
        psiblast_file= ss_blast round: 2 nseq: 0 max_e: 0
        /md1/anirbang/Software/Prof/src/Prof tmp0.922131.align fileRdb=tmp0.666513.out sec ascii
        bad option tmp0.922131.align
        bad option fileRdb=tmp0.666513.out
        bad option sec
        bad option ascii
        file of secondary structure output not found
        In automatic mode :
        usage is Prof -A -v -d -m 0 -i [filename in fasta format] -b [database name for psiblast] -o [filename for the output]
        Or if you want a casp format as output
        usage is Prof -c -v -d -m 0 -i [filename in fasta format] -b [database name for psiblast] -o [filename for the output]



        In non-automatic mode :
        usage is Prof -A -v -d -m 1 -a [Output from clustalw in aln format] -p [Output profil form psi-blast] -o [filename for the output]
        Or if you want a casp format as output
        usage is Prof -c -v -d -m 1 -a [Output from clustalw in aln format] -p [Output profil form psi-blast] -o [filename for the output]

        file of sequence not found. With option [-m 0] need file of sequence in fasta format.
        prof failed: maybe too many sequences?? 1
        Traceback (most recent call last):
        File “/md1/anirbang/Software/ROSETTA/rosetta_fragments/nnmake/run_prof.py”, line 323, in ?
        data = open(tmp_outfile,’r’)
        IOError: [Errno 2] No such file or directory: ‘tmp0.666513.out’
        cmd is: /md1/anirbang/Software/ROSETTA/rosetta_fragments/nnmake/run_prof.py 1l2y_.fasta ss_blast 1l2y_.prof_rdb
        psiblast_file= ss_blast round: 1 nseq: 0 max_e: 0
        psiblast_file= ss_blast round: 2 nseq: 0 max_e: 0
        /md1/anirbang/Software/Prof/src/Prof tmp0.532689.align fileRdb=tmp0.151388.out sec ascii
        bad option tmp0.532689.align
        bad option fileRdb=tmp0.151388.out
        bad option sec
        bad option ascii
        file of secondary structure output not found
        In automatic mode :
        usage is Prof -A -v -d -m 0 -i [filename in fasta format] -b [database name for psiblast] -o [filename for the output]
        Or if you want a casp format as output
        usage is Prof -c -v -d -m 0 -i [filename in fasta format] -b [database name for psiblast] -o [filename for the output]



        In non-automatic mode :
        usage is Prof -A -v -d -m 1 -a [Output from clustalw in aln format] -p [Output profil form psi-blast] -o [filename for the output]
        Or if you want a casp format as output
        usage is Prof -c -v -d -m 1 -a [Output from clustalw in aln format] -p [Output profil form psi-blast] -o [filename for the output]

        file of sequence not found. With option [-m 0] need file of sequence in fasta format.
        prof failed: maybe too many sequences?? 1
        Traceback (most recent call last):
        File “/md1/anirbang/Software/ROSETTA/rosetta_fragments/nnmake/run_prof.py”, line 323, in ?
        data = open(tmp_outfile,’r’)
        IOError: [Errno 2] No such file or directory: ‘tmp0.151388.out’
        prof failed.



        Can you please tell me what is going wrong here? Why PROF is not running, although the standalone version of PROF is running fine. Any suggestion is welcome. Thanks a lot.

        Regards,

        Anirban

    Viewing 0 reply threads
    • You must be logged in to reply to this topic.