problems in building rosetta3.1 (solved)

Member Site Forums Rosetta 3 Rosetta 3 – General problems in building rosetta3.1 (solved)

  • This topic has 1 reply, 2 voices, and was last updated 14 years ago by Anonymous.
Viewing 1 reply thread
  • Author
    Posts
    • #603
      Anonymous

        after typing “scons bin mode=release”, i got into troubles, the error information is as below:

        ^sophia@sophia-laptop:~/rosetta_source$ scons bin mode=release
        scons: Reading SConscript files …

        scons: warning: The Options class is deprecated; use the Variables class instead.
        File “/home/sophia/.local/share/Trash/files/rosetta_source/tools/build/setup.py”, line 45, in setup_build_options

        scons: warning: The EnumOption() function is deprecated; use the EnumVariable() function instead.
        File “/home/sophia/.local/share/Trash/files/rosetta_source/tools/build/setup.py”, line 53, in setup_build_options

        scons: warning: The ListOption() function is deprecated; use the ListVariable() function instead.
        File “/home/sophia/.local/share/Trash/files/rosetta_source/tools/build/setup.py”, line 61, in setup_build_options
        svn: ‘.’ is not a working copy
        scons: done reading SConscript files.
        scons: Building targets …
        g++ -o build/src/release/linux/2.6/64/x86/gcc/protocols/toolbox/PoseMetricCalculators/ResidueDecompositionCalculator.os -c -std=c++98 -pipe -ffor-scope -W -Wall -pedantic -Wno-long-long -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -fPIC -DNDEBUG -Isrc -Iexternal/include -Isrc/platform/linux/64/gcc -Isrc/platform/linux/64 -Isrc/platform/linux -Iexternal/boost_1_38_0 -I/usr/local/include -I/usr/include src/protocols/toolbox/PoseMetricCalculators/ResidueDecompositionCalculator.cc
        src/protocols/toolbox/PoseMetricCalculators/ResidueDecompositionCalculator.cc: In member function ‘void protocols;;toolbox;;PoseMetricCalculators;;ResidueDecompositionCalculator;;residue_set_numbers_to_decomposition()’:
        src/protocols/toolbox/PoseMetricCalculators/ResidueDecompositionCalculator.cc:155: internal compiler error: Segmentation fault
        Please submit a full bug report,
        with preprocessed source if appropriate.
        See for instructions.

        scons: *** [build/src/release/linux/2.6/64/x86/gcc/protocols/toolbox/PoseMetricCalculators/ResidueDecompositionCalculator.os] Error 1
        scons: building terminated because of errors.^

        my gcc version is 4.2.4 and scons is 1.2.0, 2.6.31-21-generic x86_64 GNU/Linux,
        Does anyone know how to solve it ? Many thanks…(:razz:)

        SOLVED
        I think it’s something about gtk,gcc,g++. I have installed gcc and g++ before, just now I installed gtk, then it worked !!!
        Maybe my enviroments for building was not satisfied then.

      • #4427
        Anonymous

          I’m glad you solved it.

          This is a known error in gcc 4.2.4. We’ve seen a similar error in 4.4.1.

          The solution I suggest is to install a different version of gcc and use “overrides” flags in user.settings to force compilation with a different gcc version. If you got it working with a different fix, great!

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.