Problems in installing Rosetta3 in Red Hat Linux

Member Site Forums Rosetta 3 Rosetta 3 – General Problems in installing Rosetta3 in Red Hat Linux

Viewing 1 reply thread
  • Author
    • #362

        After I ran “python external/scons-local/”, I got the following:

        sh: svnversion: command not found sh: svn: command not found

        scons: warning: The env.Copy() method is deprecated; use the env.Clone() method instead. File “/usr/rosetta3_source/src/SConscript.src”, line 88, in ?

        I checked that there is not svn installed in the computer. Should I run the file provided in the rosetta3_source folder to install the program? What should I do to avoid the scons warning?

      • #4160

          You should be able to ignore those warnings.

          The first is caused by a version number feature used by the developers (compiles the SVN version number into the code) – we meant to remove it from the release but we forgot. If you really want to remove it you can try commenting out most of the lines in the script. I suggest ignoring it.

          The second is an internal SCons warning – again, a warning, not an error. Just ignore it (we all do).

          Check the bin/ folder – you did get the executeables you needed, right?


          Reply to above:

          Yes, I did have the executeables I needed after I installed SVN program. Rosetta 3.0 is working for the demos provided in the package.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.