Rosetta-2.3.0 build on fedora 9

Member Site Forums Rosetta++ Rosetta++ – General Rosetta-2.3.0 build on fedora 9

Viewing 1 reply thread
  • Author
    • #318


        I’ve tried to build rosetta-2.3.0 on my fedora9 system using the command “make gcc34”, which gcc34 refers to gcc version-3.4.6 as the default gcc is gcc-4.3. However, error message appeared:

        {standard input}: Assembler messages:
        {standard input}:369909: Warning: end of file not at end of a line; newline inserted
        g++: Internal error: Segmentation fault (program cc1plus)
        Please submit a full bug report.
        See <> for instructions.
        make: *** [.gcc34.pose_dna.o] Error 1
        make: *** Deleting file `.gcc34.pose_dna.o’

        could anyone help with this? as i am new to linux system.

        and, here’s what i get if i tried to use scons with the command “scons compiler=gcc compiler_version=3.4.6 os=linux arch=x86 mode=release”:

        Traceback (most recent call last):
        File “/home/aik.khoon/rosetta++/SConstruct”, line 86, in main
        build = SConscript(“tools/build/”)
        File “/usr/lib/scons/SCons/Script/”, line 596, in __call__
        return apply(method, args, kw)
        File “/usr/lib/scons/SCons/Script/”, line 533, in SConscript
        return apply(_SConscript, [self.fs,] + files, subst_kw)
        File “/usr/lib/scons/SCons/Script/”, line 256, in _SConscript
        exec _file_ in call_stack[-1].globals
        File “/home/aik.khoon/rosetta++/tools/build/”, line 356, in
        build = setup()
        File “/home/aik.khoon/rosetta++/tools/build/”, line 347, in setup
        build.options_requested, build.options = setup_build_options()
        File “/home/aik.khoon/rosetta++/tools/build/”, line 95, in setup_build_options
        supported, actual.cxx, requested.cxx_ver
        File “/home/aik.khoon/rosetta++/tools/build/”, line 77, in select_compiler_version
        (actual, compiler)
        KeyError: “Unknown version number 4.3 for compiler ‘gcc'”
        scons: done reading SConscript files.
        scons: Building targets …
        scons: `.’ is up to date.
        scons: done building targets.


      • #4034

          I never had a luck with Fedora 9 because I couldn’t get GCC 3.4 installed. However, I used Fedora 7, which came with GCC 4.1 that could successfully build Rosetta. You have to use make gcc.

          Make sure you have the setup you need in Fedora 7, such as the programmer tools. This website helps: Personal Fedora 7 Installation Guide. Mauriat Miranda. June 19, 2008.

          When I tried to build Rosetta, I found one necessary step:
          cp rosetta++/src/platform/Linux/platform/types.hh rosetta++/src/platform/  Copy a header file that tells the makefile what platform Rosetta will be running on.
          You will need to do this if you get “types.hh file not found” error.

          If you make a mistake and need to recompile, type make clean before make gcc, so that you have a clean start.

          Good luck

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.