rosetta 3.3 compile error

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install rosetta 3.3 compile error

Viewing 4 reply threads
  • Author
    Posts
    • #1185
      Anonymous

        I have two computers´╝Ť the old one compiled well and the program ran well.but the new one I tried everything
        and could not compile correctly.
        the error line mostly like this:

        /tmp/cc9VrS4H.s: Assembler messages:
        /tmp/cc9VrS4H.s:31770: Error: unknown pseudo-op: `.uleb128′
        scons: *** [build/src/release/linux/2.6/64/x86/gcc/protocols/toolbox/pose_metric_calculators/DecomposeAndReweightEnergiesCalculator.os] Error 1
        scons: building terminated because of errors.

        I have tried Ubuntu 10.10, 11.10; fedora 14, 15
        gcc 4.4 4.5 4.6
        change the finline-limit to 200

        should that be the hardware problem?
        I have changed the memory card and also it doesn’t work.

        what can I do to overcome this problem?
        Thanks in advance.

      • #6723
        Anonymous

          Rosetta 3.2 is also tried, doesn’t work.

        • #6729
          Anonymous

            I’ve never seen that before, but it looks to be an assembler issue. If the assembler is choking on the assembly code that gcc is putting out, that’s likely a problem with your build system, rather than Rosetta itself. I would have said there was a problem with your gcc installation, but since you see the problem on multiple gccs/platforms, that’s unlikely to be the case.

            My guess is that your environment is set up to compile for a platform/system where gcc has issues. (What hardware are you using? Do you typically do cross-compiling with gcc? Have you done any tweaks to the build system from the default install of Ubuntu/Fedora?)

            Googling “uleb128” indicates that it’s a debugging-related item, so you might want to try compiling the release mode (adding mode=release to your scons command line) – this will also *greatly* speed up your runs. There’s really no reason not to use the mode=release version unless you’re actively debugging something.

          • #6739
            Anonymous

              Thanks for reply.
              I did use the command “mode=release”.
              the motherboard I use is ASUS P8H61.
              During the installation of Ubuntu, it always stalled because of errors,
              and I am sure that the installation disk is OK.
              I don’t hnow how to cross-compiling with gcc, would you kindly tell me how to do it.

            • #6750
              Anonymous

                If you installed multiple GCC versions onto one computer, you need to use a flag cxx_ver as an argument to scons to tell it which gcc you want. Like: “scons.py bin mode=release cxx=gcc cxx_ver=4.4”.

                I’ve never seen a problem like this and I’m not sure it’s Rosetta related – does anything else compile? Have you tried a hello world test?

              • #6754
                Anonymous

                  If you had issues installing the operating system itself, that’s probably the bigger issue to address. Rosetta (or any program) isn’t going to work well if your operating system has errors in it, and that’s not something Rosetta can work around. If you’re sure the Ubuntu installation disk is OK, you may have hardware issues. I’ve found that the Ubuntu forums are a great place to get help regarding installing Ubuntu and diagnosing related hardware issues.

                  By the way, you don’t need to do cross-compiling. I just mentioned it because if you were doing some cross-compiling and forgot about it, the compiler settings might have been left in a bad state. (It doesn’t sound like that’s the case – the OS installation errors are your likely problem.)

              Viewing 4 reply threads
              • You must be logged in to reply to this topic.