Rosetta 3.3 installation in linux

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install Rosetta 3.3 installation in linux

Viewing 2 reply threads
  • Author
    • #1343


        I ‘m experiencing an error with Rosetta 3.3 installation in CentOS (free OS of Red hat Enterprise) virtual machine. Its version is 5.8 for a 32bit windows machine. Once i successfully installed scons, i ran this command
        “scons bin mode=release” to install rosetta with root permissions in my virtual machine. After a 2 hour compilation, it gave an error saying that it couldn’t find “lz” file in my root directory. Below is the error message. Any help on this is appreciated.

        /usr/bin/ld: cannot find -lz
        collect2: ld returned 1 exit status
        scons: *** [build/src/release/linux/2.6/32/x86/gcc/] Error 1
        scons: building terminated because of errors.


      • #7400

          It looks like you don’t have the zlib/gzip libraries installed. (You need the developers’ version with the compilation headers.) I don’t know what the package is called on CentOS, it’s probably something like “zlib-devel”.

        • #9893

            Can anyone please provide details regarding zlib installation?
            I am trying to install rosetta3.3 on a server. I have copied precompiled files from another location. but, it is giving same error as mentioned above. yum is also not available on server.

          • #9896

              How you accomplish a zlib installation is entirely dependent on what distribution you use. Most distributions have some sort of package manager. RedHat and the like may use yum to do it, Debian and Ubuntu have apt-get, Gentoo has portage, and there are a number of different graphical package managers as well. I would talk to the system administrator of the machine you’re using, and ask them to install the zlib library for you.

              It is possible to manually compile and install zlib in a user’s home directory, but it’s much easier if you get the sysadmin to use the distributions normal installation machinery.

          Viewing 2 reply threads
          • You must be logged in to reply to this topic.