Rosetta 3.4 build on Fedora 15 (VM)

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install Rosetta 3.4 build on Fedora 15 (VM)

Viewing 1 reply thread
  • Author
    • #1247

        Dear All,

        Because I cannot build Rosetta 3.4 on Mac OS X Lion yet, I tried a virtual machine of Fedora 15 with VirtualBox. Here I describe some issues:

        1. After installing Fedora I made the following updates / installations:
        $ sudo yum install scons
        $ sudo yum update gcc-c++

        2. I run the following command in the source code folder of Rosetta:

        $ scons bin mode=release

        3. When compiling, the process stopped because of the following errors:

        $ g++-4.6: command not found
        $ gcc-4.6: command not found

        4. So I checked the version of the compiler:

        $ gcc -v
        gcc version 4.6.3 20120306 (Red Hat 4.6.3-2) (GCC)

        5. Then, I search for the gcc command

        $ whereis gcc
        gcc: /usr/bin/gcc

        6. I created symbolic links in the same folder where the commands are:

        $ cd /usr/bin
        $ sudo ln -s gcc gcc-4.6
        $ sudo ln -s g++ g++-4.6

        7. Finally, I run the compilation again and after 3 hrs I got the binaries (symbolic links to the binaries) in bin folder.

        I hope this information be useful.


      • #7533

          Thanks!!! I appreciate it.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.