Rosetta 3.4 on Mac OS X v 10.6.8

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install Rosetta 3.4 on Mac OS X v 10.6.8

Viewing 5 reply threads
  • Author
    • #1493


        I just downloaded Rosetta 3.4 from the RosettaCommons website and am trying to compile it. However, it keeps failing with the following message (while Rosetta 3.3 compiles fine) :

        Processor: 2.66 GHz Intel Core i&
        Memory: 8 GB 1067 MHz DDR3
        Command Line: (executed from within rosetta_source directory): ./ bin mode=release

        g++-4.0 -o build/src/release/macos/10.6/64/x86/gcc/4.0/basic/options/keys/OptionKeys0.os -c -isystem external/boost_1_46_1/boost/ -isystem external/boost_1_46_1/boost/ –param inline-unit-growth=1000 –param large-function-growth=50000 -m64 -march=nocona -mtune=generic -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -fPIC -DNDEBUG -Isrc -Iexternal/include -Isrc/platform/macos/64/gcc/4.0 -Isrc/platform/macos/64/gcc -Isrc/platform/macos/64 -Isrc/platform/macos -Iexternal/boost_1_46_1 -Iexternal/dbio -I/usr/include -I/usr/local/include src/basic/options/keys/
        cc1plus(6866) malloc: *** mmap(size=16777216) failed (error code=12)
        *** error: can’t allocate region
        *** set a breakpoint in malloc_error_break to debug

        cc1plus: out of memory allocating 4072 bytes after a total of 0 bytes
        scons: *** [build/src/release/macos/10.6/64/x86/gcc/4.0/basic/options/keys/OptionKeys0.os] Error 1
        scons: building terminated because of errors

        Thanks for your help,

      • #8271

          Well, it certainly seems to be running out of memory. I see that the machine has 8 GB; how much is actually used by Rosetta when compiling? I’m told “activity monitor” on a Mac can do this?

          I have a vague feeling I’ve seen errors masquerading as memory errors that were actually write permissions errors, when someone tried to compile Rosetta in a directory to which they did not have write access.

        • #8272

            Well I too thought that it was something to do with memory. Thus I restarted my machine and ran it again, but the same error. Do note that I am trying to compile using gcc 4.0. It seemed to work fine for rosetta 3.3, but I know that the recommended version is gcc 3.4.x. So am trying with that now. As always, thank you for your help :)

          • #8274

              Well then. Let me try downloading the latest version of gcc and recompile

            • #8276

                I think that 3.4 might have been released during the window where certain compiler versions had a memory exhaustion error during compilation due to flag settings.

                Go into rosetta_source/tools/build/basic.settings, and search for “inline-unit-growth” and “large-function-growth”. Comment out all the lines which set those flags (to extremely high values), like they are for the gcc version 4.1 block. This should fix things (as would compiling with a gcc version other than 3.4 or 4.0).

              • #8277

                  Thanks! gcc 4.2 did the trick!

                • #8273

                    I can’t say that gcc 3.4 is recommended. It’s what the test server uses, but none of the developers use it. I use gcc 4.6.3 (or clang).

                Viewing 5 reply threads
                • You must be logged in to reply to this topic.