Rosetta demos error

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install Rosetta demos error

Viewing 4 reply threads
  • Author
    • #2220

        Perhaps this is a simple error due to my minimal experience, but I appear to have a good install of Rosetta on a new machine (MacOS 10.10.3). I went to run the demos and keep getting the following error:

        Encounter error while executing: bash /Users/jlburkhead/Desktop/Rosetta/demos/
        *** Test abinitio did not run! Check your –mode flag and paths. [2015-07-02 15:39:53.664224]
        Finished abinitio in 0 seconds [~ 1 test (100%) started, 0 in queue, 0 running]

        If I run the “all demos” option, it is the same error for each demo (with its respective name).

        Any ideas?


        The rest of the output is below, with three demo errors included. I do find it strange that the source directory has a missing folder in the path, but specifying the entire path doesn’t change the output.

        casits-iMac:demos jlburkhead$ python -s ~/Rosetta/main/source/ -d ~/Rosetta/main/database/
        Using Rosetta source dir at: /Users/jlburkhead/Rosetta/main/source
        Using Rosetta tools dir at: /Users/jlburkhead/Desktop/Rosetta/tools
        Removing old run-dir:…
        ### This exists: public/0_HOW_TO_MAKE_DEMOS/command
        ~~~ public/0_HOW_TO_MAKE_DEMOS
        ### This exists: public/abinitio/command
        ~~~ public/abinitio
        ### This exists: public/abinitio_fold_and_dock_of_peptides_using_FlexPepDock/command
        ~~~ public/abinitio_fold_and_dock_of_peptides_using_FlexPepDock
        ### This exists: public/abinitio_w_chemicalshift_NOE/command
        ~~~ public/abinitio_w_chemicalshift_NOE
        ### This exists: public/abinitio_w_chemicalshift_NOE_rdc/command
        ~~~ public/abinitio_w_chemicalshift_NOE_rdc
        ### This exists: public/abinitio_w_chemicalshift_only/command
        ~~~ public/abinitio_w_chemicalshift_only
        ### This exists: public/analyzing_interface_quality/command
        ~~~ public/analyzing_interface_quality
        ### This exists: public/analyzing_structure_quality/command
        ~~~ public/analyzing_structure_quality
        ### This exists: public/calculate_protein_protein_ddg/command
        ~~~ public/calculate_protein_protein_ddg
        ### This exists: public/darc/command
        ~~~ public/darc
        ### This exists: public/dock_protein_complex_with_ligand_XML/command
        ~~~ public/dock_protein_complex_with_ligand_XML
        ### This exists: public/doug_dock_design_min_mod2_cal_cal/command
        ~~~ public/doug_dock_design_min_mod2_cal_cal
        ### This exists: public/enzyme_design/command
        ~~~ public/enzyme_design
        ### This exists: public/ligand_dock_commandline/command
        ~~~ public/ligand_dock_commandline
        ### This exists: public/local_dock_ssrA_peptide_against_sspB/command
        ~~~ public/local_dock_ssrA_peptide_against_sspB
        ### This exists: public/loop_delete_sample/command
        ~~~ public/loop_delete_sample
        ### This exists: public/optimize_ligand_hydroxyl_hydrogens/command
        ~~~ public/optimize_ligand_hydroxyl_hydrogens
        ### This exists: public/prepare_pdb_for_rosetta_with_relax/command
        ~~~ public/prepare_pdb_for_rosetta_with_relax
        ### This exists: public/prepare_pdbs_for_rosetta/command
        ~~~ public/prepare_pdbs_for_rosetta
        ### This exists: public/Refinement_of_protein_peptide_complex_using_FlexPepDock/command
        ~~~ public/Refinement_of_protein_peptide_complex_using_FlexPepDock
        ### This exists: public/rna_mutate/command
        ~~~ public/rna_mutate
        ### This exists: public/rna_thread/command
        ~~~ public/rna_thread
        ### This exists: public/symmetric_docking_insulin_trimer_of_dimers/command
        ~~~ public/symmetric_docking_insulin_trimer_of_dimers
        Running Test 0_HOW_TO_MAKE_DEMOS
        bash /Users/jlburkhead/Desktop/Rosetta/demos/
        Finished 0_HOW_TO_MAKE_DEMOS in 0 seconds [~ 62 test (73%) started, 22 in queue, 0 running]
        Running Test abinitio
        bash /Users/jlburkhead/Desktop/Rosetta/demos/

        Encounter error while executing: bash /Users/jlburkhead/Desktop/Rosetta/demos/
        *** Test abinitio did not run! Check your –mode flag and paths. [2015-07-02 15:29:31.174453]
        Finished abinitio in 0 seconds [~ 63 test (75%) started, 21 in queue, 0 running]
        Running Test abinitio_fold_and_dock_of_peptides_using_FlexPepDock
        bash /Users/jlburkhead/Desktop/Rosetta/demos/

        Encounter error while executing: bash /Users/jlburkhead/Desktop/Rosetta/demos/
        *** Test abinitio_fold_and_dock_of_peptides_using_FlexPepDock did not run! Check your –mode flag and paths. [2015-07-02 15:29:31.180414]
        Finished abinitio_fold_and_dock_of_peptides_using_FlexPepDock in 0 seconds [~ 64 test (76%) started, 20 in queue, 0 running]
        Running Test abinitio_w_chemicalshift_NOE
        bash /Users/jlburkhead/Desktop/Rosetta/demos/
        Follow instructions in README to prepare input files
        Now picking chemical shift fragments, will takes about 10 mins

        Encounter error while executing: bash /Users/jlburkhead/Desktop/Rosetta/demos/
        *** Test abinitio_w_chemicalshift_NOE did not run! Check your –mode flag and paths. [2015-07-02 15:29:31.186290]
        Finished abinitio_w_chemicalshift_NOE in 0 seconds [~ 65 test (77%) started, 19 in queue, 0 running]
        Running Test abinitio_w_chemicalshift_NOE_rdc
        bash /Users/jlburkhead/Desktop/Rosetta/demos/
        Follow instructions in README to prepare input files
        Now picking chemical shift fragments, will takes about 10 mins

      • #11069

          Interesting – I don’t seem to have a problem with the abinitio demo on my machine. (The demos are currently not tested regularly, so there’s always a chance that one or more of them are broken.)

          In the /Users/jlburkhead/Desktop/Rosetta/demos/ directory there should be a “log” file. What are the contents of this file? Are there any error messages being printed?

        • #11072


            thank you very much for taking a look and commenting. I have attached the log file from abinitio here. It does look like something worked, but I am still learning the program, so I can’t confidently interpret how this compares to the errors given.


          • #11082

              Interesting. It should be 3.5, as I downloaded the .tgz 2015.05. The demos are those that were downloaded in the package. Curiously, I downloaded the most recent release and tried to build it last night on another mac, but it gave errors on the build that I have yet to sort out.

              The download file name for what I have posted there is: rosetta_bin_mac_2015.05.57576_bundle.tgz, which I would assume is 3.5.

            • #11252

                Demos again.

                I am slowly trying to learn the functionality of Rosetta through the demos, but I wonder if there is something not quite right in the current file.

                For each test, including abinitio, I get an “Encounter error while executing:” and “*** Test abinitio did not run!  Check your –mode flag and paths.”

                Each test has the same message. 

                What is strange is that the abinitio test does run and produces the expected output. I even deleted the outputs and re-ran the tests to check this. results.json also indicates that everything failed. The log under abinitio indicates no errors save for warnings for missing heavyatom

                If anyone has and ideas, I am open. I realize that the demos aren’t explicitly maintained, but knowing that they are correct might make them more useful as a guide for learning.



              • #11074

                  Which version of the demos are you running, and what version of Rosetta?

                  From best I can tell, it looks like have a recent version of the demos, but you’re trying to run them with an older version of Rosetta (Rosetta3.3?).

                  You’ll want to run the version of the demos which correspond to the version of Rosetta you’re using. (… and unless you’re trying to recapitulate older results, you probably should be using one of the recent weekly releases.)

                • #11264

                    There might be something off with the demos running script. Getting the demos to be run and checked for a working state against the most recent version of Rosetta is something on the communities todo list, but it isn’t something that’s currently working.

                    At any rate, there’s only a limited value in you (the end user) running the demos from the demos running script. The value of the demos is primarily in working through the examples yourself, step by step, looking at how things are set up and run. You should do this just for the demos you’re interested in. If you encounter problems with that way of running, then you can troubleshoot the individual lines at issue, and/or post your question about what’s not working to the forums here.

                Viewing 4 reply threads
                • You must be logged in to reply to this topic.