Rosetta installation

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install Rosetta installation

Viewing 7 reply threads
  • Author
    • #3691

        i am trying to install rosette latest version in ubuntu 10.10.
        i have installed scons and python as minimum requirmnets.
        Now how to buld rosetta…

        while i am running command like :

        # scons

        here i am getting error.

        scons bin mode=release
        scons bin
        scons -h
        scons -H

        What to do next….
        can anybody help me out?

      • #5592

          What error do you get?

        • #5637

            Here the last lines when i used 2 in place of #……..Most of the time i got error like … o: not found

            sh: o: not found
            gcc -o build/src/release/linux/2.6/32/x86/gcc/ -shared -Llib -Lexternal/lib -Lbuild/src/release/linux/2.6/32/x86/gcc -Lsrc -L/usr/local/lib -L/usr/lib -lprotocols -lcore -lnumeric -lutility -lObjexxFCL -lz
            /usr/bin/ld: cannot find -lprotocols
            collect2: ld returned 1 exit status
            o build/src/release/linux/2.6/32/x86/gcc/apps/public/comparative_modeling/cluster_alns.o -c -std=c++98 -pipe -ffor-scope -W -Wall -pedantic -Wno-long-long -malign-double -march=pentium4 -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000 -s -Wno-unused-variable -DNDEBUG -Isrc -Iexternal/include -Isrc/platform/linux/32/gcc -Isrc/platform/linux/32 -Isrc/platform/linux -Iexternal/boost_1_38_0 -I/usr/local/include -I/usr/include src/apps/public/comparative_modeling/
            scons: *** [build/src/release/linux/2.6/32/x86/gcc/] Error 1
            sh: o: not found
            scons: building terminated because of errors.

          • #6722

              I tried to install the rosetta3.3_bundles on Fedora14 on Linuxi686 system.
              I install scons and when try to run scons bin mode=release in the directry /root/Desktop/rosetta3.3_bundles/rosetta_source/tools/build/ i got the error message

              scons: *** No SConstruct file found.
              File “/usr/lib/scons/SCons/Script/”, line 904, in _main

              How to solve this problem..
              thank you.

            • #8700

                I have done the building part in installation by typing

                scons bin
                scons bin mode=release

                which says “scons: done building targets”

                Now next step is Additional Build Environment Options for which i get

                scons bin my_pilot_apps

                **scons: building terminated because of errors**

                Could you please tell me what is the next step to be followed after building. how to make File target `my_pilot_apps’?

                Please help!

              • #9639

                  Hello Sir, I am very new user to CS-rosetta…….

                  I have download and compile the weakly released package W52 by using command ./ mode=release bin -j 8.
                  and output look like this building has done..
                  but at the next step I am installing Toolbox, Error come as in the terminal….

                  user@user-HCL-Desktop:~$ ls
                  csrosetta3 Music project.git Videos
                  Desktop NMR_Pipe_7.9 Public zlib-1.2.8
                  Documents NMRViewJ rosetta_2013wk52_bundle
                  Downloads nvjinstall8_0_3.jar Templates
                  examples.desktop Pictures Ubuntu One
                  user@user-HCL-Desktop:~$ cd csrosetta3
                  user@user-HCL-Desktop:~/csrosetta3$ ls
                  com database flag_library frag_picker python tests tutorials
                  user@user-HCL-Desktop:~/csrosetta3$ ./
                  delete pyc files from
                  AUTO-DETECTED: Running on linux…
                  AUTO-DETECTION: check $PATH
                  AUTO-DETECTION: look in $HOME/rosetta
                  AUTO-DETECTION FAILED: cannot find ROSETTA binaries.
                  Run with -rosetta to point to binaries if toolbox is intended for automatic setup of CS-ROSETTA calculations
                  AUTO-DETECTION FAILED: cannot find ROSETTA database.
                  Run with -rosetta_database to point to database if toolbox is intended for automatic setup of CS-ROSETTA calculations
                  check whether dunbrack library can be loaded from the binary file…
                  /bin/sh: 1: None/score_jd2.default.linuxgccrelease: not found
                  /bin/sh: 1: None/score_jd2.default.linuxgccrelease: not found
                  Traceback (most recent call last):
                  File “./”, line 330, in
                  if not check_dunbrack_library( rosetta_db_path, rosetta_bin, build, platform, final_msgs ):
                  File “./”, line 322, in check_dunbrack_library
                  OSError: [Errno 2] No such file or directory: ‘’

                  Thank you very Much in advance……

                • #15335

                    Dear developers, 

                    I have the same problem (comment above)

                    In How to use Rosetta options and the Command Line ( ubuntu 10.04)

                    while i am using below command line in terminal at home dir of roesetta_sourse

                    fixbb:linuxgccrelease -in:……………..

                    Error is : fixbb.linuxgccrelease: command not found

                    In the bin folder are all the compiled documents and still I get this error.

                    I would appreciate your suggestions and recommendations


                    • #15382

                        Generally speaking, you don’t want to be running Rosetta from within the source directory. You typically want to be within your working directory (e.g. the data directory in your home directory which has all your input files) and then invoke the Rosetta command with a full path (e.g. `~/Rosetta/main/source/bin/fixbb.linuxgccrelease …`)

                        If you want, there are ways to add that path to the shell’s PATH variable, so your shell will seach for it automatically without the path, but that’s independent of Rosetta and the details of how to do that depend a bit on your shell.

                    • #15477

                        Hi. When i am installing rosetta, in the final step: rosetta*/main/source/

                        ./ -j * mode = release bin (* number of cores).

                        The terminal throws me the following message: “/ usr / bin / env: <<python>>: The file or directory does not exist”, I do not understand the reason for this message, I have already installed scons, gcc and python. Can you help me?

                      • #5605

                          In How to use Rosetta options and the Command Line ( ubuntu 10.04)

                          while i am using below command line in terminal at home dir of roesetta_sourse

                          fixbb:linuxgccrelease -in:……………..

                          Error is : fixbb.linuxgccrelease: command not found

                          So here what is fixbb

                          how to solve this error.Pls help me out..

                          Thank you

                        • #5606

                            You need to give it the path to the Rosetta executeable; Rosetta does not modify your command line environment. I don’t know where you put it, but it will be something like /PATH/TO/ROSETTA/rosetta_source/bin/fixbb.linuxgccrelease. You’ll need to fill in the first parts.

                            If the folder rosetta_source/bin is empty, then you haven’t compiled Rosetta yet via SCons; let me know what error message SCons gives and I can try to help.

                          • #5620

                              Thank you for your reply.

                              yes as you said the folder rosetta_source/bin is empty….there ie no fixbb.linuxgccrelease file…
                              How to compile Rosetta via Scons..? Here Can you give me step by step instructions for compilation

                            • #5621

                                Go to your rosetta_source folder.

                                There should be a symlink to

                                Type “python -j# bin mode=release”. The # symbol should be replaced with the number of processors you have to compile on (if it’s a 4-core machine, try 3, if it’s only a single processor machine, leave it at 1.)

                                It should spit out many, many lines that read “g++ -o build/src/release” and take a fair amount of time to compile (many hours if you only use one processor).

                                Post the last five or so lines of output when it finishes and I’ll see if it looks good. It should say “scons: done building targets” if it encountered no errors.

                              • #5636

                                  Here the last five lines:

                                  File “”, line 162, in
                                  gcc -o build/src/release/linux/2.6/32/x86/gcc/ -shared -Llib -Lexternal/lib -Lbuild/src/release/linux/2.6/32/x86/gcc -Lsrc -L/usr/local/lib -L/usr/lib -lprotocols -lcore -lnumeric -lutility -lObjexxFCL -lz
                                  /usr/bin/ld: cannot find -lprotocols
                                  collect2: ld returned 1 exit status
                                  scons: *** [build/src/release/linux/2.6/32/x86/gcc/] Error 1
                                  scons: building terminated because of errors.

                                • #5651

                                    The o: command not solved bug is due to SCons failing to find your compiler. This was how another user got it fixed:


                                    We can explore other methods if that post doesn’t work.

                                  • #5664

                                      it doesn’t work.As per that i am unable to update user.settings file…..

                                    • #5669

                                        What do you mean by “unable to update”? You don’t have write permissions on the file…?

                                      • #5671

                                          yes… If you are free, Is it possible to connect to my system through TEAM VIEWER.

                                          I have tried all options.can i have your mail id ,so that i can communicate easily….If you fell free.. you can mail to me..

                                 is my mail id….

                                          Thank you.

                                        • #5675

                                            I can’t do anything about it if you don’t have write permissions to your own files. Let me be more clear about how to check:

                                            Go to the tools/build directory (???/rosetta_source/tools/build)

                                            Type in “ls -l”, and let me know what it returns. The pattern on the left should start “-rw-r–r–“, which means you have permissions to read and write the file. If it doesn’t start that way, then you need to start from scratch by untar-ing the Rosetta tarball someplace where you will have write permissions.

                                          • #6726

                                              Scons needs to be run from within the rosetta_source/ directory.

                                            • #6731


                                              • #8702

                                                  Is there an additional pilot app you wish to build? The release version of Rosetta doesn’t come with the (unreleased) developer pilot apps. (And the internal developer version compiles them automatically.)

                                                  The only reason you would have do something like compile “my_pilot_apps” is if you have created your own application and wish to compile it. – And in that case, I’d recommend dispensing with the whole pilot app machinery and just putting the application .cc file in the src/apps/public directory, and modifying src/apps.src.settings directly. (Just repeat the original scons command(s), and your new application should compile.) You’re not redistributing the application, so you really don’t need to worry about the public/pilot distinction.

                                              Viewing 7 reply threads
                                              • The topic ‘Rosetta installation’ is closed to new replies.