rosetta on snow leopard?

Member Site Forums Rosetta 3 Rosetta 3 – General rosetta on snow leopard?

Viewing 3 reply threads
  • Author
    • #352

        Hello — I just sent this email to the support team, but I figured I’d post it here just in case someone in the community has solved it already.

        i just tried to compile Rosetta3.0 on my laptop, and at the very end I
        get the following error:

        g++ -o build/src/release/macos/10.0/64/x86/gcc/AbinitioRelax.macosgccrelease
        -Llib -Lexternal/lib -Lbuild/src/release/macos/10.0/64/x86/gcc -Lsrc
        -L/usr/local/lib -L/usr/lib -lprotocols -lcore -lnumeric -lutility
        -lObjexxFCL -lz
        ld: segments overlap: __PAGEZERO (0x00000000 + 0x100000000) and
        __UNIXSTACK (0xBC000000 + 0x04000000)
        collect2: ld returned 1 exit status
        scons: *** [build/src/release/macos/10.0/64/x86/gcc/AbinitioRelax.macosgccrelease]
        Error 1
        scons: building terminated because of errors.

        is there something I can do about this?
        My computer is OSX 10.6.1.

      • #4212

          There has been some discussion of Snow Leopard compiling amongst the developers recently but I do not think it centered on weird linker errors, I think it was issues with SCons autodetection of processor architecture. I’ll ask around.

        • #4217

            For reference, I had already figured out one fix on my own, commenting out the:
            # “compile” : [ “march=prescott” ],
            line from basic.settings, so that’s why the error I reported is different from the first error that someone else might see. :-)

            But I replaced those 3 files with yours, and it compiled just fine. Thanks!

          • #4218

              i’m sorry, I’m not sure what I just did, but it looked like I managed to overwrite your post with my reply…. and in the process attaching your name as the author of my post. :-(

              i don’t know if there’s a way to fix this, so I’ll just go ahead and repost the link from the post I “deleted” with the patch files:


          Viewing 3 reply threads
          • You must be logged in to reply to this topic.