Rosetta problems: terminate called after throwing an instance of ‘std::string’

Member Site Forums Rosetta 3 Rosetta 3 – Build/Install Rosetta problems: terminate called after throwing an instance of ‘std::string’

Viewing 2 reply threads
  • Author
    • #2045

        Hi, Im new to Rosetta and these forums, but I have a problem running Rosetta. I’ve compiled on a CentOS machine, but I keep getting segmentation faults and crashes,

        e.g. I try to run AbinitioRelax.default.linuxgccrelease –help

        But it crashes in the midst of output with

        rmsd_dump | 2 | R| dump all pdbs for loops that
        | | | are below in rmsd
        terminate called after throwing an instance of ‘std::string’
        Abort (core dumped)

        This is the same for all executables I’ve tried with the –help switch. I also see crashes with other switches.

        What can be the issue? Something in the compile process? 64bit issues? I’m a bit clueless on how to trouble shoot the issue, so all suggestions are welcome. I already recompiled it once.

        Im on a centos 6.5 system with gcc -v 4.4.7.

        gcc -v
        Using built-in specs.
        Target: x86_64-redhat-linux
        Configured with: ../configure –prefix=/usr –mandir=/usr/share/man –infodir=/usr/share/info –with-bugurl= –enable-bootstrap –enable-shared –enable-threads=posix –enable-checking=release –with-system-zlib –enable-__cxa_atexit –disable-libunwind-exceptions –enable-gnu-unique-object –enable-languages=c,c++,objc,obj-c++,java,fortran,ada –enable-java-awt=gtk –disable-dssi –with-java-home=/usr/lib/jvm/java-1.5.0-gcj- –enable-libgcj-multifile –enable-java-maintainer-mode –with-ecj-jar=/usr/share/java/eclipse-ecj.jar –disable-libjava-multilib –with-ppl –with-cloog –with-tune=generic –with-arch_32=i686 –build=x86_64-redhat-linux
        Thread model: posix
        gcc version 4.4.7 20120313 (Red Hat 4.4.7-4) (GCC)

        The compilation went seemingly without errors after I got the dependencies solved (zlib zlib-devel) and for mpi compile I used the site.settings.topsail after installing the openmpi-devel.x86_64 openmpi.x86_64 packages and setting the paths and include before compile:
        export PATH=/usr/lib64/openmpi/bin/:$PATH
        export INCLUDE=/usr/include/openmpi-x86_64:/usr/include/openmpi-x86_64/openmpi/ompi/mpi:/usr/include/openmpi-x86_64/openmpi/ompi/mpi/cxx:/usr/include/openmpi-x86_64/vampirtrace

      • #10489

          That’s not anything to be worried about. I get the same behavior. — When you use the option “-help” (N.B. Rosetta uses single dashes for it’s options, rather than double dashes), Rosetta displays the help message and immediately exits. The way that it exits, though, is being treated as an “Abort”. Don’t worry, it’s an *intentional* abort, as we don’t want to try to run the program if all you wanted was the help message.

        • #10502

            Thanks, this is reassuring to hear, but to me the help message seems a bit truncated, but I’m not sure. It would be helpfull if anyone could send the output of the help from an executable with the -help, so that I can compare.


          • #10506

              It’s not cut off – that’s the extent of the -help message for the Abinitio application. (~470 lines, ending with the rmsd_dump option).

              The intent of the -help message was to give you a brief overview of relevant options for a particular application. Each application thus has a different message printed when -help is given. I say “intent”, because it’s not all that successful even at just listing relevant options. The relevant options have to be manually added to the list to be printed, and this doesn’t always happen when a program gets written or updated.

              Instead of looking at the information printed by -help, I would rather encourage you to look at the corresponding pages on the User Guide ( ) This has a higher likelihood of being a good explanation of how to use the program, including an explanation of any scientific caveats to be aware of.

              If you instead just want a full list of most of the 3000+ options Rosetta understands, see Keep in mind, though, that a large number of those are application specific ones and are not relevant for most applications.

          Viewing 2 reply threads
          • You must be logged in to reply to this topic.